# After upgrade error message

**URL:** <https://discourse.nodered.org/t/after-upgrade-error-message/16478>\
**Category:** General\
**Created:** [8 October 2019 17:22 UTC](https://discourse.nodered.org/t/after-upgrade-error-message/16478 "2019-10-08T17:22:41Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![menno](https://avatars.discourse-cdn.com/v4/letter/m/dec6dc/32.png) [@menno](https://discourse.nodered.org/u/menno)\
**Post date:** [8 October 2019 17:22 UTC](https://discourse.nodered.org/t/after-upgrade-error-message/16478/1 "2019-10-08T17:22:41Z")

</div>

Hi guys  
after upgrading i still have the RED error on top of my page

**Using an unsupported version of Node.js**  
**You should upgrade to the latest Node.js LTS release**

can you guys please help me with this  
i googled and googled but can not find the solution

my config:

# nvm list

-\> v8.16.1  
v10.16.3  
system  
default -\> v6.17.1  
node -\> stable (-\> v10.16.3) (default)  
stable -\> 10.16 (-\> v10.16.3) (default)  
iojs -\> N/A (default)  
unstable -\> N/A (default)  
lts/\* -\> lts/dubnium (-\> v10.16.3)  
lts/argon -\> v4.9.1  
lts/boron -\> v6.17.1  
lts/carbon -\> v8.16.1  
lts/dubnium -\> v10.16.3

# node -v

v8.16.1

# npm -v

6.4.1

please help me ... many thanks in advance  
m

---

<div class="post-metadata">

**Author:** ![cymplecy](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/cymplecy/32/2773_2.png) [@cymplecy](https://discourse.nodered.org/u/cymplecy)\
**Post date:** [8 October 2019 17:29 UTC](https://discourse.nodered.org/t/after-upgrade-error-message/16478/2 "2019-10-08T17:29:45Z")

</div>

what OS are you on?

---

<div class="post-metadata">

**Author:** ![menno](https://avatars.discourse-cdn.com/v4/letter/m/dec6dc/32.png) [@menno](https://discourse.nodered.org/u/menno)\
**Post date:** [8 October 2019 17:31 UTC](https://discourse.nodered.org/t/after-upgrade-error-message/16478/3 "2019-10-08T17:31:54Z")

</div>

sorry .. forgot that

# cat /etc/centos-release

CentOS Linux release 7.7.1908 (Core)

---

<div class="post-metadata">

**Author:** ![knolleary](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/knolleary/32/3_2.png) [@knolleary](https://discourse.nodered.org/u/knolleary)\
**Post date:** [8 October 2019 17:45 UTC](https://discourse.nodered.org/t/after-upgrade-error-message/16478/4 "2019-10-08T17:45:19Z")

</div>

How are you running Node-RED? You are using nvm as your local user. If you are running NR as a service then it won't be picking up your local user nvm settings and will use whatever version of node you have installed globally.

---

<div class="post-metadata">

**Author:** ![menno](https://avatars.discourse-cdn.com/v4/letter/m/dec6dc/32.png) [@menno](https://discourse.nodered.org/u/menno)\
**Post date:** [8 October 2019 18:18 UTC](https://discourse.nodered.org/t/after-upgrade-error-message/16478/5 "2019-10-08T18:18:01Z")

</div>

yes as a service ...  
temporary fixed it with restoring : /usr/lib/node\_modules  
and /root/.node-red & /root/.npm

will build a new server this or next week with centos 8 .. so i will try again later  
thanks for the help so far  
m
