# \[ANNOUNCE\]node-red-contrib-xterm : second beta (sidebar)

**URL:** <https://discourse.nodered.org/t/announce-node-red-contrib-xterm-second-beta-sidebar/19718>\
**Category:** Share Your Nodes\
**Created:** [30 December 2019 00:16 UTC](https://discourse.nodered.org/t/announce-node-red-contrib-xterm-second-beta-sidebar/19718 "2019-12-30T00:16:47Z")\
**Posts on this page:** 1\
**Showing post:** 32

<div class="post-metadata">

**Author:** ![Trying\_to\_learn](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/trying_to_learn/32/28400_2.png) [@Trying\_to\_learn](https://discourse.nodered.org/u/Trying_to_learn)\
**Post date:** [1 January 2020 09:22 UTC](https://discourse.nodered.org/t/announce-node-red-contrib-xterm-second-beta-sidebar/19718/32 "2020-01-01T09:22:28Z")

</div>

Thanks.

Ok. I need to restart NR. My bad. Just I didn't read it at the link.

Also the message that resulted from the install has me a bit worried.

```auto
me@me-desktop:~/.node-red$ npm install bartbutenaers/node-red-contrib-xterm
npm WARN bootstrap@4.3.1 requires a peer of jquery@1.9.1 - 3 but none is installed. You must install peer dependencies yourself.
npm WARN node-red-contrib-ui-led@0.3.1 requires a peer of node-red-dashboard@2.14.x but none is installed. You must install peer dependencies yourself.
npm WARN xterm-addon-fit@0.3.0 requires a peer of xterm@^4.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN node-red-project@0.0.1 No repository field.
npm WARN node-red-project@0.0.1 No license field.

+ node-red-contrib-xterm@0.0.1
updated 1 package and audited 1788 packages in 6.904s
found 11 vulnerabilities (3 low, 1 moderate, 7 high)
  run `npm audit fix` to fix them, or `npm audit` for details
me@me-desktop:~/.node-red$ 

```

`7 high security risks!`

Shall restart NR and see what happens.

Restarted and all good.

---

_[View the full topic](https://discourse.nodered.org/t/announce-node-red-contrib-xterm-second-beta-sidebar/19718)._
