[beta testing] nodes for live streaming mp4

Hi. Im using exec node for my rtsp url which is ffmpeg -loglevel quiet -rtsp_transport tcp -i rtsp://xxxx@192.168.1.xxx:554//h264Preview_01_main -an -c:v copy -f mp4 -movflags +frag_keyframe+empty_moov+default_base_moof pipe:1. and connect the node to mp4frag and ui_mp4frag nodes by Kevin Godell. After deploy i only see video playback ready sign at dashboard. How to solve this?

Your rtsp url. Does it work in VLC?. I do not have rtsp cameras myself but the link below normally works (when the camera is available). Try your rtsp url first in VLC, if it doesn't work there, no idea to try further until fixed. Also check how you have configured the ui_mp4frag node

ffmpeg -loglevel quiet -rtsp_transport tcp -i rtsp://freja.hiof.no:1935/rtplive/_definst_/hessdalen03.stream -an -c:v copy -f mp4 -movflags +frag_every_frame+empty_moov+default_base_moof -min_frag_duration 500000 pipe:1

i already fix it. i move the mp4 to the top of the order. and it display on dashboard. just sometime the video stream dont have a good quality

mp4 is mp4
Quality is best when there is less movement in view. Principle for mp4 is to transfer not complete images but the difference from frame to frame. Check now what durations you get. Eventually reduce duration and resolution in camera setting. Try socket.io and see if it is better

i see. thank you for the info. where to check the duration?

You see it at the mp4frag nodes when the stream is running. How to change in the camera setting is camera device specific, if possible. The ultimate goal is to have short durations to reduce delay in view related to the actual real world

image

okay thank you very much