# Cannot start service nodered: Address already in use

**URL:** https://discourse.nodered.org/t/cannot-start-service-nodered-address-already-in-use/83972
**Category:** General
**Created:** [22 December 2023 21:36 UTC](https://discourse.nodered.org/t/cannot-start-service-nodered-address-already-in-use/83972 "2023-12-22T21:36:51Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Shwowak](https://avatars.discourse-cdn.com/v4/letter/s/7bcc69/32.png) [@Shwowak](https://discourse.nodered.org/u/Shwowak)
#### Post date: [22 December 2023 21:36 UTC](https://discourse.nodered.org/t/cannot-start-service-nodered-address-already-in-use/83972/1 "2023-12-22T21:36:51Z")

</div>

ERROR: for nodered Cannot start service nodered: Address already in use

ERROR: for nodered Cannot start service nodered: Address already in use  
ERROR: Encountered errors while bringing up the project.

---

<div class="post-metadata">

### Author: ![zenofmud](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/zenofmud/32/316_2.png) [@zenofmud](https://discourse.nodered.org/u/zenofmud)
#### Post date: [22 December 2023 21:41 UTC](https://discourse.nodered.org/t/cannot-start-service-nodered-address-already-in-use/83972/2 "2023-12-22T21:41:53Z")

</div>

Are you sure node-red is not already running?

What happens if you run node-red-stop

---

<div class="post-metadata">

### Author: ![marcus-j-davies](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/marcus-j-davies/32/103435_2.png) [@marcus-j-davies](https://discourse.nodered.org/u/marcus-j-davies)
#### Post date: [22 December 2023 21:47 UTC](https://discourse.nodered.org/t/cannot-start-service-nodered-address-already-in-use/83972/3 "2023-12-22T21:47:44Z")

</div>

As per @zenofmud - you are:

- Already running Node RED
- Something else is using port **1880**

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)
#### Post date: [20 February 2024 21:48 UTC](https://discourse.nodered.org/t/cannot-start-service-nodered-address-already-in-use/83972/4 "2024-02-20T21:48:38Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
