# \[error\] Error: EACCES: permission denied,

**URL:** https://discourse.nodered.org/t/error-error-eacces-permission-denied/42300
**Category:** General
**Created:** [9 March 2021 04:13 UTC](https://discourse.nodered.org/t/error-error-eacces-permission-denied/42300 "2021-03-09T04:13:39Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![12345](https://avatars.discourse-cdn.com/v4/letter/1/ec9cab/32.png) [@12345](https://discourse.nodered.org/u/12345)
#### Post date: [9 March 2021 04:13 UTC](https://discourse.nodered.org/t/error-error-eacces-permission-denied/42300/1 "2021-03-09T04:13:39Z")

</div>

hello. what should i do?  
9 Mar 10:55:04 - [info]

# Welcome to Node-RED

9 Mar 10:55:04 - [info] Node-RED version: v1.2.9  
9 Mar 10:55:04 - [info] Node.js version: v8.10.0  
9 Mar 10:55:04 - [info] Linux 5.4.0-66-generic x64 LE  
9 Mar 10:55:05 - [info] Loading palette nodes  
9 Mar 10:55:05 - [error] Failed to start server:  
9 Mar 10:55:05 - [error] Error: EACCES: permission denied, unlink '/home/krittapak/.node-red/.config.nodes.json.backup'

---

<div class="post-metadata">

### Author: ![kuema](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/kuema/32/6542_2.png) [@kuema](https://discourse.nodered.org/u/kuema)
#### Post date: [9 March 2021 06:03 UTC](https://discourse.nodered.org/t/error-error-eacces-permission-denied/42300/2 "2021-03-09T06:03:51Z")

</div>

I'd check if the files in your `~/.node-red` directory are owned by the correct user (`krittapak` in your case).

How did you start Node-RED? Did you - by any chance - run it as `root` before? That would explain the permission issues.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)
#### Post date: [23 March 2021 06:03 UTC](https://discourse.nodered.org/t/error-error-eacces-permission-denied/42300/3 "2021-03-23T06:03:55Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
