# Error : node not deployed

**URL:** <https://discourse.nodered.org/t/error-node-not-deployed/22029>\
**Category:** Dashboard\
**Created:** [20 February 2020 19:39 UTC](https://discourse.nodered.org/t/error-node-not-deployed/22029 "2020-02-20T19:39:52Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![DidierWindey](https://avatars.discourse-cdn.com/v4/letter/d/b9e5f3/32.png) [@DidierWindey](https://discourse.nodered.org/u/DidierWindey)\
**Post date:** [20 February 2020 19:39 UTC](https://discourse.nodered.org/t/error-node-not-deployed/22029/1 "2020-02-20T19:39:52Z")

</div>

Suddenly Node-red gives a problem on deploying after even the smallest editing on a flow. Giving 'error: node not deployed' and the dashboard does not start (only the start screen with the Node Red logo).

On deploying a pop-up says : "the server is running a more recent set of flows. The changes include no conflicts and can be merged automatically.  
and 3 buttons : review changes, merge, ignore deploy.

On review changes, I then try to merge.  
another pop-up : The flows on the server have been updated.  
then the 'error: node not deployed' pops up...

Even stopping and starting Node Red (even in safe mode) does not do anything. Only a system reboot wil load the dashboard again.

running on a raspberry pi, with recent update/upgrade

20 Feb 20:21:20 - [info] Node-RED version: v1.0.3  
20 Feb 20:21:20 - [info] Node.js version: v10.19.0  
20 Feb 20:21:20 - [info] Linux 4.19.80-v7+ arm LE  
20 Feb 20:21:22 - [info] Loading palette nodes  
20 Feb 20:21:36 - [info] Dashboard version 2.19.1 started at /ui  
20 Feb 20:21:36 - [info] Settings file : /home/pi/.node-red/settings.js  
20 Feb 20:21:36 - [info] Context store : 'storeInFile' [module=localfilesystem]  
20 Feb 20:21:36 - [info] Context store : 'default' [module=memory]  
20 Feb 20:21:36 - [info] User directory : /home/pi/.node-red  
20 Feb 20:21:36 - [warn] Projects disabled : editorTheme.projects.enabled=false  
20 Feb 20:21:36 - [info] Flows file : /home/pi/.node-red/flows\_theone.json  
20 Feb 20:21:37 - [error] Unable to listen on [http://127.0.0.1:1880/](http://127.0.0.1:1880/)  
20 Feb 20:21:37 - [error] Error: port in use

anyone knows how to fix ?  
Didier

---

<div class="post-metadata">

**Author:** ![afelix](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/afelix/32/9743_2.png) [@afelix](https://discourse.nodered.org/u/afelix)\
**Post date:** [20 February 2020 19:57 UTC](https://discourse.nodered.org/t/error-node-not-deployed/22029/2 "2020-02-20T19:57:06Z")

</div>

> [@DidierWindey](#):
>
> 20 Feb 20:21:37 - [error] Unable to listen on [http://127.0.0.1:1880/](http://127.0.0.1:1880/)  
> 20 Feb 20:21:37 - [error] Error: port in use

You’re running node-red in another process on the same machine too. That’s why what you see in the browser wasn’t the actual flow deployed

---

<div class="post-metadata">

**Author:** ![DidierWindey](https://avatars.discourse-cdn.com/v4/letter/d/b9e5f3/32.png) [@DidierWindey](https://discourse.nodered.org/u/DidierWindey)\
**Post date:** [20 February 2020 20:21 UTC](https://discourse.nodered.org/t/error-node-not-deployed/22029/3 "2020-02-20T20:21:39Z")

</div>

I never had this before. How to fix ?

---

<div class="post-metadata">

**Author:** ![Colin](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/colin/32/17040_2.png) [@Colin](https://discourse.nodered.org/u/Colin)\
**Post date:** [20 February 2020 20:41 UTC](https://discourse.nodered.org/t/error-node-not-deployed/22029/4 "2020-02-20T20:41:43Z")

</div>

How are you stopping node red and how are you starting it? You should be using node-red-stop and node-red-start.

---

<div class="post-metadata">

**Author:** ![DidierWindey](https://avatars.discourse-cdn.com/v4/letter/d/b9e5f3/32.png) [@DidierWindey](https://discourse.nodered.org/u/DidierWindey)\
**Post date:** [22 February 2020 16:45 UTC](https://discourse.nodered.org/t/error-node-not-deployed/22029/5 "2020-02-22T16:45:41Z")

</div>

Fixed it

I have no idea why, but I think node-red got corrupted.  
I deleted all node-red files and restoreded a backup.  
Everything seems to work again now.

Didier

---

<div class="post-metadata">

**Author:** ![gbuurman](https://avatars.discourse-cdn.com/v4/letter/g/22d042/32.png) [@gbuurman](https://discourse.nodered.org/u/gbuurman)\
**Post date:** [23 February 2020 12:35 UTC](https://discourse.nodered.org/t/error-node-not-deployed/22029/6 "2020-02-23T12:35:24Z")

</div>

I had the same issue and there where two things. First when you starts nom use another starting port or you are using a soapserver node.

Solutions:  
start with another portnumer for nom and/or the soapserver.  
Regards  
Ger

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)\
**Post date:** [24 March 2020 12:35 UTC](https://discourse.nodered.org/t/error-node-not-deployed/22029/7 "2020-03-24T12:35:26Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
