# error on start of node-red

**URL:** <https://discourse.nodered.org/t/error-on-start-of-node-red/20447>\
**Category:** General\
**Created:** [16 January 2020 12:09 UTC](https://discourse.nodered.org/t/error-on-start-of-node-red/20447 "2020-01-16T12:09:13Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![yordi](https://avatars.discourse-cdn.com/v4/letter/y/ad7895/32.png) [@yordi](https://discourse.nodered.org/u/yordi)\
**Post date:** [16 January 2020 12:09 UTC](https://discourse.nodered.org/t/error-on-start-of-node-red/20447/1 "2020-01-16T12:09:13Z")

</div>

node-red : File C:\Users\me\AppData\Roaming\npm\node-red.ps1 cannot be loaded because running scripts is disabled on  
this system. For more information, see about\_Execution\_Policies at https:/go.microsoft.com/fwlink/?LinkID=135170.  
At line:1 char:1

- node-red
- 

```auto
  + CategoryInfo : SecurityError: (:) [], PSSecurityException
  + FullyQualifiedErrorId : UnauthorizedAccess
```

---

<div class="post-metadata">

**Author:** ![bakman2](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/bakman2/32/6207_2.png) [@bakman2](https://discourse.nodered.org/u/bakman2)\
**Post date:** [16 January 2020 15:24 UTC](https://discourse.nodered.org/t/error-on-start-of-node-red/20447/2 "2020-01-16T15:24:23Z")

</div>

Did you follow the link that was shown in the error ?  
Security problem.

How did you try to start node-red ?  
What commandline ?  
Powershell ?  
Does it have admin rights ?

In powershell (admin) you can enter

```auto
Set-ExecutionPolicy -ExecutionPolicy RemoteSigned

```

and retry. Note that this changes a security parameter on your system.

---

<div class="post-metadata">

**Author:** ![mrkazoodle](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/mrkazoodle/32/44318_2.png) [@mrkazoodle](https://discourse.nodered.org/u/mrkazoodle)\
**Post date:** [3 July 2021 15:42 UTC](https://discourse.nodered.org/t/error-on-start-of-node-red/20447/3 "2021-07-03T15:42:12Z")

</div>

First of al: thanks!

In addition: this seems to be a policy that is different for Windows Server and normal Windows computers, and running Node Red on a normal PC seems to require changing this policy. This is something they should mention in the documentation
