# Error permission denied certificates | OPC UA IIoT Flex Server

**URL:** https://discourse.nodered.org/t/error-permission-denied-certificates-opc-ua-iiot-flex-server/10488
**Category:** General
**Created:** [24 April 2019 07:00 UTC](https://discourse.nodered.org/t/error-permission-denied-certificates-opc-ua-iiot-flex-server/10488 "2019-04-24T07:00:21Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![carlosglez](https://avatars.discourse-cdn.com/v4/letter/c/4af34b/32.png) [@carlosglez](https://discourse.nodered.org/u/carlosglez)
#### Post date: [24 April 2019 07:00 UTC](https://discourse.nodered.org/t/error-permission-denied-certificates-opc-ua-iiot-flex-server/10488/1 "2019-04-24T07:00:21Z")

</div>

I am using the package "node-red-contrib-iiot-opcua".

The problem is that when I try to deploy a flow I get the problem that you can see in the following screenshot. I don't know how to fix it.

 ![error_flexserver_opcuaiiot](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/2X/4/481c1434c3ee6a1b69d275dbcacc429cae2db017.png)

The flow is working on a Raspberry with Raspbian GNU/Linux 9 (stretch). My Node-RED version is "0.20.0" and mi Node version is 10.5.3.

Thank you!

---

<div class="post-metadata">

### Author: ![ukmoose](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/ukmoose/32/13_2.png) [@ukmoose](https://discourse.nodered.org/u/ukmoose)
#### Post date: [24 April 2019 07:13 UTC](https://discourse.nodered.org/t/error-permission-denied-certificates-opc-ua-iiot-flex-server/10488/2 "2019-04-24T07:13:25Z")

</div>

So what user and what are the permissions on the file it is complaining about?

---

<div class="post-metadata">

### Author: ![carlosglez](https://avatars.discourse-cdn.com/v4/letter/c/4af34b/32.png) [@carlosglez](https://discourse.nodered.org/u/carlosglez)
#### Post date: [24 April 2019 07:30 UTC](https://discourse.nodered.org/t/error-permission-denied-certificates-opc-ua-iiot-flex-server/10488/3 "2019-04-24T07:30:05Z")

</div>

I'm newbie and I do not know how to check that. But I'm using the raspberry with the default user

---

<div class="post-metadata">

### Author: ![ukmoose](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/ukmoose/32/13_2.png) [@ukmoose](https://discourse.nodered.org/u/ukmoose)
#### Post date: [24 April 2019 07:36 UTC](https://discourse.nodered.org/t/error-permission-denied-certificates-opc-ua-iiot-flex-server/10488/4 "2019-04-24T07:36:04Z")

</div>

cd into the directory and then list the files with  
`ls -l`

The user that you are running Node-RED as needs to have permission to read the file.  
Here's a page that will explain unix permissions:  
[https://wiki.archlinux.org/index.php/File\_permissions\_and\_attributes](https://wiki.archlinux.org/index.php/File_permissions_and_attributes)

If you look at the directory listing and the user you are using to run Node-RED can't access the file then try changing the owner and permissions so that they can read the file.

---

<div class="post-metadata">

### Author: ![Colin](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/colin/32/17040_2.png) [@Colin](https://discourse.nodered.org/u/Colin)
#### Post date: [24 April 2019 08:07 UTC](https://discourse.nodered.org/t/error-permission-denied-certificates-opc-ua-iiot-flex-server/10488/5 "2019-04-24T08:07:16Z")

</div>

Exactly what command did you use to install the node?

---

<div class="post-metadata">

### Author: ![carlosglez](https://avatars.discourse-cdn.com/v4/letter/c/4af34b/32.png) [@carlosglez](https://discourse.nodered.org/u/carlosglez)
#### Post date: [24 April 2019 08:15 UTC](https://discourse.nodered.org/t/error-permission-denied-certificates-opc-ua-iiot-flex-server/10488/6 "2019-04-24T08:15:45Z")

</div>

I solved it by using: "sudo chmod -R 777 " followed by the path

---

<div class="post-metadata">

### Author: ![Colin](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/colin/32/17040_2.png) [@Colin](https://discourse.nodered.org/u/Colin)
#### Post date: [24 April 2019 08:59 UTC](https://discourse.nodered.org/t/error-permission-denied-certificates-opc-ua-iiot-flex-server/10488/7 "2019-04-24T08:59:21Z")

</div>

chown pi:pi might have been better.
