# Error: Server responded with a non-101 status: 429

**URL:** <https://discourse.nodered.org/t/error-server-responded-with-a-non-101-status-429/3366>\
**Category:** General\
**Created:** [23 September 2018 03:10 UTC](https://discourse.nodered.org/t/error-server-responded-with-a-non-101-status-429/3366 "2018-09-23T03:10:08Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![SteveMann](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/stevemann/32/3810_2.png) [@SteveMann](https://discourse.nodered.org/u/SteveMann)\
**Post date:** [23 September 2018 03:10 UTC](https://discourse.nodered.org/t/error-server-responded-with-a-non-101-status-429/3366/1 "2018-09-23T03:10:08Z")

</div>

I am getting this error in my debug panel:

```
Error: Server responded with a non-101 status: 429 
Too Many Requests
Response Headers Follow:
date: Sat, 22 Sep 2018 22:51:23 GMT
content-length: 0
content-type: text/plain; charset=utf-8

```

And, I don't have a clue which node is causing it.  
I would appreciate some pointers toward finding the cause of this error, and, please, if you say "Check the logs", please tell me which log files and where are they.

Thanks

---

<div class="post-metadata">

**Author:** ![ukmoose](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/ukmoose/32/13_2.png) [@ukmoose](https://discourse.nodered.org/u/ukmoose)\
**Post date:** [23 September 2018 07:30 UTC](https://discourse.nodered.org/t/error-server-responded-with-a-non-101-status-429/3366/2 "2018-09-23T07:30:55Z")

</div>

The log location is dependent on which OS you have installed Node-RED and how you have decided to run it.

---

<div class="post-metadata">

**Author:** ![knolleary](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/knolleary/32/3_2.png) [@knolleary](https://discourse.nodered.org/u/knolleary)\
**Post date:** [23 September 2018 07:39 UTC](https://discourse.nodered.org/t/error-server-responded-with-a-non-101-status-429/3366/3 "2018-09-23T07:39:11Z")

</div>

What nodes do you have in your flow that make http requests to online services? That will help narrow it down.

---

<div class="post-metadata">

**Author:** ![SteveMann](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/stevemann/32/3810_2.png) [@SteveMann](https://discourse.nodered.org/u/SteveMann)\
**Post date:** [23 September 2018 11:23 UTC](https://discourse.nodered.org/t/error-server-responded-with-a-non-101-status-429/3366/4 "2018-09-23T11:23:56Z")

</div>

> [@ukmoose](#):
>
> The log location is dependent on which OS you have installed Node-RED and how you have decided to run it.

Thanks for the reply. I forgot to add my sig file- But it's the Node-Red that comes with Stretch. I don't see any log files in **~/.node-red**

![Sig](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/2X/8/87494c8512470399062d2299b339f0275c0994e1.jpg)

---

<div class="post-metadata">

**Author:** ![SteveMann](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/stevemann/32/3810_2.png) [@SteveMann](https://discourse.nodered.org/u/SteveMann)\
**Post date:** [23 September 2018 11:26 UTC](https://discourse.nodered.org/t/error-server-responded-with-a-non-101-status-429/3366/5 "2018-09-23T11:26:48Z")

</div>

> [@knolleary](#):
>
> What nodes do you have in your flow that make http requests to online services?

Thanks, I appreciate the reply.  
I must be slow today, but it's either my IP camera or Weather Underground.

**EDIT: Turns out to be my PushBullet node.**

![Sig](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/2X/8/87494c8512470399062d2299b339f0275c0994e1.jpg)

---

<div class="post-metadata">

**Author:** ![ukmoose](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/ukmoose/32/13_2.png) [@ukmoose](https://discourse.nodered.org/u/ukmoose)\
**Post date:** [23 September 2018 11:38 UTC](https://discourse.nodered.org/t/error-server-responded-with-a-non-101-status-429/3366/6 "2018-09-23T11:38:46Z")

</div>

If it’s on stretch you probably need to update your signature.

If you run Node-RED using node-red-start the location of the log file is listed on the raspberry pi page in the docs under the systemd part.

---

<div class="post-metadata">

**Author:** ![TotallyInformation](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/totallyinformation/32/31_2.png) [@TotallyInformation](https://discourse.nodered.org/u/TotallyInformation)\
**Post date:** [23 September 2018 12:13 UTC](https://discourse.nodered.org/t/error-server-responded-with-a-non-101-status-429/3366/7 "2018-09-23T12:13:24Z")

</div>

To view the log if running under systemd (typical now for nearly all Linux OS's I think), use the `journalctl` command.

For example, I have a small flow that issues the following in an exec node:

```auto
sudo journalctl -u nrlive -f -n 0 -o cat

```

`nrlive` is my instance of Node-RED (slightly different to the default). You can play with the parameters to get different outputs.

I also add a log command to my `package.json` file since I can never remember the actual command. That way I can do something like `npm run log` in my userDir folder.

---

<div class="post-metadata">

**Author:** ![SteveMann](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/stevemann/32/3810_2.png) [@SteveMann](https://discourse.nodered.org/u/SteveMann)\
**Post date:** [24 September 2018 01:09 UTC](https://discourse.nodered.org/t/error-server-responded-with-a-non-101-status-429/3366/9 "2018-09-24T01:09:10Z")

</div>

> [@ukmoose](#):
>
> If it’s on stretch you probably need to update your signature.

Thanks. The sig is correct. It can't be Stretch because the good people at Raspberry decided to not make Node-Red preinstalled beginning with Stretch.

---

<div class="post-metadata">

**Author:** ![TotallyInformation](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/totallyinformation/32/31_2.png) [@TotallyInformation](https://discourse.nodered.org/u/TotallyInformation)\
**Post date:** [24 September 2018 06:13 UTC](https://discourse.nodered.org/t/error-server-responded-with-a-non-101-status-429/3366/10 "2018-09-24T06:13:58Z")

</div>

> [@SteveMann](#):
>
> Thanks. The sig is correct. It can't be Stretch because the good people at Raspberry decided to not make Node-Red preinstalled beginning with Stretch.

In my opinion, that's for the best. Previously, the default Node.JS installation was a mess because they needed to keep the archive size low. It caused lots of confusion. Though it also resulted in Dave's excellent update script so ...

Also, there are more than one ways to install Node-RED. Either way, unpicking the default install was a pain.

Of course, it did have the impact of raising the awareness of Node-RED with Pi users which was very good. Not sure we need that quite so much though now that NR is much more visible.
