'ET Display Home' a flow to help manage your ESPeasy, Sonoff/Tasmota and Homie flashed devices (now on GitHub)

Just added v0.1.9 which adds code to allow you to delete 'Ghost' nodes. - A 'Ghost' IP is one from a device where you change it's original IP address after it has been discovered.

Also added some color to the display.

Hi Paul,
Just tried release v0.1.9 - works like a dream.
Thanks for all your hard work on this project.

I will also have a look at it. @dynamicdave linked me here :slight_smile:
If you need some more info in the JSON, please ask.
Also a high-res logo is available if you ever need one :wink:

Attached is the latest release (V0.1.10). This release handle changes in the names returned by the ESPeasy JSON object.

ET_Display_Home_v0110.json (43.7 KB)

1 Like

Attached is the latest release (V0.1.11) - a performance enhancement. The original version used nmap to get the IPs and I switched to using arp. Much faster!

ET_Display_Home.0.1.11.json (42.9 KB)


Tried installing this flow and got unknown sqlite

I have installed sqlitedb but cannot install node-red-node-sqlite as it shows conflict in palette manager.

Any idea as to what I have done wrong?



Hi lan,

  1. what version of NR and node.js? (you can see the vesrsion numbers in the node-red startup log)
  2. Are you running this on a RPI?

if so can you open a terminal window and type:
cat .node-red/package.json
and paste the results.

Then shutdown NR and in terminal enter

cd .node-red
npm install node-red-contrib-sqlite

and copy and paste the results.



Info requested

Welcome to Node-RED
10 Jun 14:17:59 - [info] Node-RED version: v0.20.5
10 Jun 14:17:59 - [info] Node.js  version: v8.14.0
10 Jun 14:17:59 - [info] Linux 4.9.35-v7+ arm LE
10 Jun 14:18:00 - [info] Loading palette nodes
10 Jun 14:18:08 - [info] Worldmap version 2.0.12
10 Jun 14:18:10 - [info] Dashboard version 2.15.4 started at /ui
10 Jun 14:18:10 - [info] Settings file  : /home/pi/.node-red/settings.js
10 Jun 14:18:10 - [info] Context store  : 'default' [module=memory]
10 Jun 14:18:10 - [info] User directory : /home/pi/.node-red
10 Jun 14:18:10 - [warn] Projects disabled : set editorTheme.projects.enabled=true to enable
10 Jun 14:18:10 - [info] Flows file     : /home/pi/.node-red/flows_NodeRedV2.json
10 Jun 14:18:10 - [info] Server now running at
10 Jun 14:18:11 - [info] Starting flows
10 Jun 14:18:12 - [info] [worldmap:Where am I? ] started at /worldmap
10 Jun 14:18:12 - [info] [worldmap:Home] started at /worldmap
10 Jun 14:18:12 - [info] Started flows
10 Jun 14:18:12 - [info] [mqtt-broker:Normal] Connected to broker: mqtt://

cat .node-red/package.json

  "name": "node-red-project",
  "description": "A Node-RED Project",
  "version": "0.0.1",
  "dependencies": {
    "fs-extra": "^7.0.1",
    "node-red-admin": "^0.1.5",
    "node-red-contrib-bigtimer": "~2.1.9",
    "node-red-contrib-debounce": "0.0.2",
    "node-red-contrib-esplogin": "~1.3.7",
    "node-red-contrib-hs100": "~0.4.0",
    "node-red-contrib-ibm-watson-iot": "^0.2.8",
    "node-red-contrib-ifttt": "~0.3.1",
    "node-red-contrib-owntracks": "0.0.2",
    "node-red-contrib-play-audio": "~2.3.2",
    "node-red-contrib-schedex": "~1.6.0",
    "node-red-contrib-sonoff-server": "^1.0.0",
    "node-red-contrib-sqlitedb": "~1.4.0",
    "node-red-contrib-telegrambot": "~5.5.0",
    "node-red-contrib-ui_list": "^0.1.3",
    "node-red-contrib-web-worldmap": "~2.0.12",
    "node-red-dashboard": "~2.15.4",
    "node-red-node-dropbox": "^1.0.2",
    "node-red-node-email": "~1.4.0",
    "node-red-node-geofence": "~0.1.1",
    "node-red-node-ledborg": "0.0.21",
    "node-red-node-pi-sense-hat": "0.0.18",
    "node-red-node-ping": "0.0.16",
    "node-red-node-pushover": "0.0.14",
    "node-red-node-random": "~0.1.2",
    "node-red-node-serialport": "~0.6.8",
    "node-red-node-smooth": "~0.1.0",
    "node-red-node-twilio": "~0.1.0"

pi@NodeRedV2:~/.node-red $ npm install node-red-contrib-sqlite

npm ERR! No valid versions available for node-red-contrib-sqlite

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/pi/.npm/_logs/2019-06-10T14_21_10_553Z-debug.log
pi@NodeRedV2:~/.node-red $



Where did you get instructions on installing the sqlite node?
It isn't called node-red-contrib-sqlite, it is node-red-node-sqlite.

I love this idea but messing with SQLite seems really overkill for this use, especially with persistent storage now available in Node-RED. Actually, I'd prefer the data simply to be read-from/written-to a json file with no SQLite at all.

@Colin > Where did you get instructions on installing the sqlite node?
It isn't called node-red-contrib-sqlite, it is node-red-node-sqlite.
My bad :flushed: I was in a rush this morning

@Ian This flow uses node-red-node-sqlite - I see you have node-red-contrib-sqlitedb installed and that may be the reason you can't install the sqlite node from the palette manager. If you are using node-red-contrib-sqlitedb then you might have to wait. I'm going to look into Jullian's idea of using persistant storage.

If you are not using ``node-red-contrib-sqlitedb, then uninstall it and try installing the sqlite nodenpm install node-red-node-sqlite`.

Many thanks. Uninstalling node-red-contrib-sqlitedb enabled me to install node-red-node-sqlite and all works as expected.

Thanks for the effort you put into this, keeping all my Sonoff devices up to date is now a whole lot easier.

Attached is the latest release (V0.1.13). This release handle a case where the ESPEasy release is bad. The mega-20190716 crashes so the code will now ignore any release with “Crashes" in it’s title so this will ignore the "mega-20190716" and display the "mega-20190630” in it’s place.

In addition there is now code to show/hide the Ghost IP delete section.
etdh_v0113.json (47.8 KB)

Hi Paul,
That will be a very useful enhancement as I was 'caught' by this release which messed-up one of my Wemos devices.

Hi @zenofmud

I had to install ET Display Home on a new Node-Red installation.

I must have gone wrong somewhere as I get the following message when I restart node red despite installing sqlite3 and node-red-node-sqlite.

5 Sep 16:33:05 - [info] Waiting for missing types to be registered:
5 Sep 16:33:05 - [info] - sqlitedb
5 Sep 16:33:05 - [info] - sqlite

Also Node-Red shows

Flows stopped due to missing node types.

  • sqlitedb
  • sqlite

Any suggestions as to where I went wrong?

Have you tried reinstalling them from the command line, but please read the install note contained in the readme first.

What version of raspibian are you running?

uname -a
Linux emonpi 4.14.71-v7+ #1145 SMP Fri Sep 21 15:38:35 BST 2018 armv7l GNU/Linux

Sorry I should have been clearer. are you running this on a pi using stretch, buster?? - you can tell by running `cat /etc/os-release'
what versions of NR and node.js?


Checking node-red version I noticed an error on start. Installed sqlite3 again and am pleased to say everything is now working as far as I can tell.

Thanks for the help.