# Failed to load resource: Unacceptable TLS certificate

**URL:** <https://discourse.nodered.org/t/failed-to-load-resource-unacceptable-tls-certificate/51947>\
**Category:** General\
**Created:** [6 October 2021 22:18 UTC](https://discourse.nodered.org/t/failed-to-load-resource-unacceptable-tls-certificate/51947 "2021-10-06T22:18:20Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![serardica](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/serardica/32/49093_2.png) [@serardica](https://discourse.nodered.org/u/serardica)\
**Post date:** [6 October 2021 22:18 UTC](https://discourse.nodered.org/t/failed-to-load-resource-unacceptable-tls-certificate/51947/1 "2021-10-06T22:18:20Z")

</div>

I was trying to use the Node-RED editor into the Internal Web Browser of eclipse, everything was going well until I go to "Manage palette" to install a new node, when I get a "Failed to load node catalogue" message,

 ![image](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/3X/b/c/bc98988425092da0780d53893078f0f35984e721.png)

in the browser's console was painted this

 ![image](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/3X/3/f/3fbe3ca5051d61bc2ff8348f7ba841934247533c.png)

If I try to open that URL [https://catalogue.nodered.org/catalogue.json](https://catalogue.nodered.org/catalogue.json) in the same Internal Web Browser I get  
 ![image](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/3X/7/e/7ebb0cb928fcc9ae9d7248d77d3ce56e7caf11cc.png)

the same "Invalid Certificate" error occurs if I try with [https://nodered.org/](https://nodered.org/) and  
[https://discourse.nodered.org/](https://discourse.nodered.org/)

Also I tried it with an external browser(Firefox) and the problem was not present there.

Note: This continues happening if I click 'no" to the "Invalid Certificate" dialog, if I click "yes" the error goes away with the requests to those URLs mentioned.

My environment is:  
RedHat Enterprise v8.1 with public internet access.  
eclipse cpp-2020-06  
Node-RED v0.20.8 running [http://locahost:1880/](http://locahost:1880/)

---

<div class="post-metadata">

**Author:** ![hardillb](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/hardillb/32/12373_2.png) [@hardillb](https://discourse.nodered.org/u/hardillb)\
**Post date:** [7 October 2021 06:52 UTC](https://discourse.nodered.org/t/failed-to-load-resource-unacceptable-tls-certificate/51947/2 "2021-10-07T06:52:21Z")

</div>

Sounds like you've probably got the problem with LetsEncrypt's root cert being switched over and there old one expiring. More details here:

> **[DST Root CA X3 Expiration (September 2021) - Let's Encrypt](https://letsencrypt.org/docs/dst-root-ca-x3-expiration-september-2021/)**
>
> Update September 30, 2021 As planned, the DST Root CA X3 cross-sign has expired, and we’re now using our own ISRG Root X1 for trust on almost all devices. For more details about the plan, keep reading! We have also updated our Production Chain...

My first suggestion would be to check for updates to any of the eclipse components mainly the browser.

---

<div class="post-metadata">

**Author:** ![serardica](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/serardica/32/49093_2.png) [@serardica](https://discourse.nodered.org/u/serardica)\
**Post date:** [7 October 2021 15:16 UTC](https://discourse.nodered.org/t/failed-to-load-resource-unacceptable-tls-certificate/51947/3 "2021-10-07T15:16:47Z")

</div>

Well I think you hit the nail on this, also explains why that was working a few weeks ago.  
Thanks @hardillb

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)\
**Post date:** [6 December 2021 15:17 UTC](https://discourse.nodered.org/t/failed-to-load-resource-unacceptable-tls-certificate/51947/4 "2021-12-06T15:17:40Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
