# Failed to start server:

**URL:** <https://discourse.nodered.org/t/failed-to-start-server/73373>\
**Category:** General\
**Created:** [8 January 2023 15:58 UTC](https://discourse.nodered.org/t/failed-to-start-server/73373 "2023-01-08T15:58:12Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![CESLBM](https://avatars.discourse-cdn.com/v4/letter/c/f14d63/32.png) [@CESLBM](https://discourse.nodered.org/u/CESLBM)\
**Post date:** [8 January 2023 15:58 UTC](https://discourse.nodered.org/t/failed-to-start-server/73373/1 "2023-01-08T15:58:12Z")

</div>

Hello, I am having this problem with node red after not using it for a longtime, how can I fix it? I am grateful that you answer my question!!

# Welcome to Node-RED

8 Jan 16:43:30 - [info] Node-RED version: v3.0.2  
8 Jan 16:43:30 - [info] Node.js version: v16.16.0  
8 Jan 16:43:30 - [info] Windows\_NT 10.0.14393 x64 LE  
8 Jan 16:43:34 - [info] Loading palette nodes  
8 Jan 16:43:42 - [info] Settings file : C:\Users\InfoLabor.node-red\settings.js  
8 Jan 16:43:42 - [info] Context store : 'default' [module=localfilesystem]  
8 Jan 16:43:43 - [error] Failed to start server:  
8 Jan 16:43:43 - [error] Error: Error loading context store: Error: Invalid JSON in context file '\Users\InfoLabor.node-red\context\8142c27a2c12d042\flow.json'  
at C:\Users\InfoLabor\AppData\Roaming\nvm\v16.16.0\node\_modules\node-red\node\_modules@node-red\runtime\lib\nodes\context\index.js:180:15

---

<div class="post-metadata">

**Author:** ![Colin](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/colin/32/17040_2.png) [@Colin](https://discourse.nodered.org/u/Colin)\
**Post date:** [8 January 2023 16:36 UTC](https://discourse.nodered.org/t/failed-to-start-server/73373/2 "2023-01-08T16:36:07Z")

</div>

> [@CESLBM](#):
>
> Error loading context store: Error: Invalid JSON in context file '\Users\InfoLabor.node-red\context\8142c27a2c12d042\flow.json'

Welcome to the forum @CESLBM  
That file is messed up. It holds the persistent context values for one of your flows. If the saved context values are not important then you can delete that file and it will be recreated when you use flow.context again. If the values are important then post the contents of that file in case it can be recovered.

---

<div class="post-metadata">

**Author:** ![TotallyInformation](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/totallyinformation/32/31_2.png) [@TotallyInformation](https://discourse.nodered.org/u/TotallyInformation)\
**Post date:** [8 January 2023 19:57 UTC](https://discourse.nodered.org/t/failed-to-start-server/73373/3 "2023-01-08T19:57:28Z")

</div>

As this is not about this forum, I've moved the Q to general.

---

<div class="post-metadata">

**Author:** ![CESLBM](https://avatars.discourse-cdn.com/v4/letter/c/f14d63/32.png) [@CESLBM](https://discourse.nodered.org/u/CESLBM)\
**Post date:** [9 January 2023 09:56 UTC](https://discourse.nodered.org/t/failed-to-start-server/73373/4 "2023-01-09T09:56:38Z")

</div>

Hi Colin,  
thanks for you reply. If I understand it right, I should delete the flow.json. After I did it, it comes another error:  
9 Jan 10:39:38 - [info] Node-RED version: v3.0.2  
9 Jan 10:39:38 - [info] Node.js version: v16.16.0  
9 Jan 10:39:38 - [info] Windows\_NT 10.0.14393 x64 LE  
9 Jan 10:39:43 - [info] Loading palette nodes  
9 Jan 10:39:53 - [info] Settings file : C:\Users\InfoLabor.node-red\settings.js  
9 Jan 10:39:53 - [info] Context store : 'default' [module=localfilesystem]  
9 Jan 10:39:53 - [error] Failed to start server:  
9 Jan 10:39:53 - [error] Error: Error loading context store: Error: Invalid JSON in context file '\Users\InfoLabor.node-red\context\global\global.json'  
at C:\Users\InfoLabor\AppData\Roaming\nvm\v16.16.0\node\_modules\node-red\node\_modules@node-red\runtime\lib\nodes\context\index.js:180:15

And when I delete this global.json, came error after the node-red is started:  
9 Jan 10:42:31 - [info] Starting flows  
9 Jan 10:42:36 - [info] Started flows  
09:42:41.753Z :client\_session\_impl :1507 [NODE-OPCUA-W21] Pending transactions: CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest  
09:42:41.763Z :client\_session\_impl :1512 [NODE-OPCUA-W22] Warning : your opcua client is sending multiple requests simultaneously to the server CreateMonitoredItemsRequest  
... please fix your application code  
9 Jan 10:42:42 - [red] Uncaught Exception:  
9 Jan 10:42:42 - [error] Error: subscription must be active and not terminated  
at assert (C:\Users\InfoLabor.node-red\node\_modules\node-opcua-assert\source\index.ts:12:21)  
at ClientSubscriptionImpl.\_add\_monitored\_item (C:\Users\InfoLabor.node-red\node\_modules\node-opcua-client\source\private\client\_subscription\_impl.ts:660:15)  
at ClientMonitoredItemImpl.\_before\_create (C:\Users\InfoLabor.node-red\node\_modules\node-opcua-client\source\private\client\_monitored\_item\_impl.ts:334:22)  
at Function.\_toolbox\_monitor (C:\Users\InfoLabor.node-red\node\_modules\node-opcua-client\source\client\_monitored\_item\_toolbox.ts:61:27)  
at C:\Users\InfoLabor.node-red\node\_modules\node-opcua-client\source\private\client\_subscription\_impl.ts:1004:40  
at Immediate.waitForSubscriptionAndMonitor (C:\Users\InfoLabor.node-red\node\_modules\node-opcua-client\source\private\client\_subscription\_impl.ts:693:17)  
at processImmediate (node:internal/timers:466:21)

Did I understand your response correctly? Could you pls give me some further advice? Thanks a lot

---

<div class="post-metadata">

**Author:** ![Steve-Mcl](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/steve-mcl/32/4826_2.png) [@Steve-Mcl](https://discourse.nodered.org/u/Steve-Mcl)\
**Post date:** [9 January 2023 10:07 UTC](https://discourse.nodered.org/t/failed-to-start-server/73373/5 "2023-01-09T10:07:46Z")

</div>

> [@CESLBM](#):
>
> 09:42:41.753Z :client\_session\_impl :1507 [NODE-OPCUA-W21] Pending transactions: CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest CreateMonitoredItemsRequest  
> 09:42:41.763Z :client\_session\_impl :1512 [NODE-OPCUA-W22] Warning : your opcua client is sending multiple requests simultaneously to the server CreateMonitoredItemsRequest  
> ... please fix your application code  
> 9 Jan 10:42:42 - [red] Uncaught Exception:  
> 9 Jan 10:42:42 - [error] Error: subscription must be active and not terminated  
> at assert (C:\Users\InfoLabor.node-red\node\_modules\node-opcua-assert\source\index.ts:12:21)  
> at ClientSubscriptionImpl.\_add\_monitored\_item (C:\Users\InfoLabor.node-red\node\_modules\node-opcua-client\source\private\client\_subscription\_impl.ts:660:15)  
> at ClientMonitoredItemImpl.\_before\_create (C:\Users\InfoLabor.node-red\node\_modules\node-opcua-client\source\private\client\_monitored\_item\_impl.ts:334:22)  
> at Function.\_toolbox\_monitor (C:\Users\InfoLabor.node-red\node\_modules\node-opcua-client\source\client\_monitored\_item\_toolbox.ts:61:27)  
> at C:\Users\InfoLabor.node-red\node\_modules\node-opcua-client\source\private\client\_subscription\_impl.ts:1004:40  
> at Immediate.waitForSubscriptionAndMonitor (C:\Users\InfoLabor.node-red\node\_modules\node-opcua-client\source\private\client\_subscription\_impl.ts:693:17)  
> at processImmediate (node:internal/timers:466:21)

In short, a node-red contrib node should handle its own errors to prevent crashing node-red.

IMO, this is a bug in the OPCUA nodes & you should raise an issue on their github repository (include the above quoted info)

---

<div class="post-metadata">

**Author:** ![CESLBM](https://avatars.discourse-cdn.com/v4/letter/c/f14d63/32.png) [@CESLBM](https://discourse.nodered.org/u/CESLBM)\
**Post date:** [9 January 2023 10:19 UTC](https://discourse.nodered.org/t/failed-to-start-server/73373/6 "2023-01-09T10:19:14Z")

</div>

Hi Steve-Mcl  
thanks a lot for the Information!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)\
**Post date:** [10 March 2023 10:19 UTC](https://discourse.nodered.org/t/failed-to-start-server/73373/7 "2023-03-10T10:19:37Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
