# Failing to start Node-Red

**URL:** https://discourse.nodered.org/t/failing-to-start-node-red/64246
**Category:** General
**Created:** [22 June 2022 16:52 UTC](https://discourse.nodered.org/t/failing-to-start-node-red/64246 "2022-06-22T16:52:32Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![afletcher](https://avatars.discourse-cdn.com/v4/letter/a/94ad74/32.png) [@afletcher](https://discourse.nodered.org/u/afletcher)
#### Post date: [22 June 2022 16:52 UTC](https://discourse.nodered.org/t/failing-to-start-node-red/64246/1 "2022-06-22T16:52:32Z")

</div>

I was up and running until my linux machine updated. Now I get the following error when attempting to start.  
/usr/bin/env: 'node': No such file or directory

Is there a way to correct this to get access to my existing flows?

As a preface I have virtually no linux programming experience. Another engineer set this up and left the company. So go easy on me!  
machine is on ubuntu 20.04.4 LTS  
Thanks

---

<div class="post-metadata">

### Author: ![Steve-Mcl](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/steve-mcl/32/4826_2.png) [@Steve-Mcl](https://discourse.nodered.org/u/Steve-Mcl)
#### Post date: [22 June 2022 17:14 UTC](https://discourse.nodered.org/t/failing-to-start-node-red/64246/2 "2022-06-22T17:14:13Z")

</div>

If the engineer set it using the recommended script, you should be able to restart the computer & the service will start node-red

However, if something has been done that is "breaking" it, you should probably try running `node-red` from a non-root account first.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)
#### Post date: [21 August 2022 17:15 UTC](https://discourse.nodered.org/t/failing-to-start-node-red/64246/3 "2022-08-21T17:15:05Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
