# Flows are gone and must be imported again

**URL:** https://discourse.nodered.org/t/flows-are-gone-and-must-be-imported-again/27448
**Category:** General
**Created:** [28 May 2020 18:37 UTC](https://discourse.nodered.org/t/flows-are-gone-and-must-be-imported-again/27448 "2020-05-28T18:37:15Z")
**Posts on this page:** 11
**Page:** 1

<div class="post-metadata">

### Author: ![mdd](https://avatars.discourse-cdn.com/v4/letter/m/43a26b/32.png) [@mdd](https://discourse.nodered.org/u/mdd)
#### Post date: [28 May 2020 18:37 UTC](https://discourse.nodered.org/t/flows-are-gone-and-must-be-imported-again/27448/1 "2020-05-28T18:37:15Z")

</div>

Hello, I had a running system with the current version. One day I couldn't open the editor and the UI anymore. No connection. Start / stop of the project was unsuccessful. Also, a restore of a few days was unsuccessful. I don't see my flows anymore. Nothing has changed in the system. Uninstall NR and copy the credential.json / flow.json after a recrystallization in the ./nodered does nothing.

The question: why is a 1: 1 backup not the NR running again? if I import the flow.json back into a new system and copy the modules in, I will be asked to install some things via npm install ... modules again.

I now have the 3 backup .. which is an IMAGE backed up. NodeRed and the flows are gone. Where's the mistake

Please excuse my bad english. Thanks to you

---

<div class="post-metadata">

### Author: ![Colin](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/colin/32/17040_2.png) [@Colin](https://discourse.nodered.org/u/Colin)
#### Post date: [28 May 2020 20:19 UTC](https://discourse.nodered.org/t/flows-are-gone-and-must-be-imported-again/27448/2 "2020-05-28T20:19:54Z")

</div>

Are you using docker?  
If you setup a simple flow and reboot without power cycle is it ok?  
If you power cycle does it all disappear again? If so then get a new SD card (assuming you or on a pi or similar).

---

<div class="post-metadata">

### Author: ![mdd](https://avatars.discourse-cdn.com/v4/letter/m/43a26b/32.png) [@mdd](https://discourse.nodered.org/u/mdd)
#### Post date: [29 May 2020 13:54 UTC](https://discourse.nodered.org/t/flows-are-gone-and-must-be-imported-again/27448/3 "2020-05-29T13:54:48Z")

</div>

Hello I am not using Docker. I have restored various backups from Raspi to another SD card, always the same result. The original .json file and all installed modules are not recognized. At some point I have reached the point where at least an empty flow from NR (http: // xxxx: 1880) is called again.

As I said, the system ran with several flows for several weeks + many restarts without problems.  
When I see the empty flow again, I can import the contents of the original Flowxxxx.json back into the editor of NR. However, at some point it is terminated with: no connection to the server (Raspi) because the modules are not available and I should install it manually, such as HUE-Bridge, openwether ........

But they are actually there, because the entire Raspi was put on a 100% copy.

---

<div class="post-metadata">

### Author: ![Colin](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/colin/32/17040_2.png) [@Colin](https://discourse.nodered.org/u/Colin)
#### Post date: [29 May 2020 14:21 UTC](https://discourse.nodered.org/t/flows-are-gone-and-must-be-imported-again/27448/4 "2020-05-29T14:21:57Z")

</div>

> [@mdd](#):
>
> The original .json file and all installed modules are not recognized.

Put the files back then run  
`node-red-stop`  
`node-red-start`  
and post the log here. That will hopefully show us something useful.

---

<div class="post-metadata">

### Author: ![mdd](https://avatars.discourse-cdn.com/v4/letter/m/43a26b/32.png) [@mdd](https://discourse.nodered.org/u/mdd)
#### Post date: [29 May 2020 14:25 UTC](https://discourse.nodered.org/t/flows-are-gone-and-must-be-imported-again/27448/5 "2020-05-29T14:25:05Z")

</div>

Thanks, I'll do that. See you in a few hours.

---

<div class="post-metadata">

### Author: ![dceejay](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/dceejay/32/38_2.png) [@dceejay](https://discourse.nodered.org/u/dceejay)
#### Post date: [29 May 2020 14:29 UTC](https://discourse.nodered.org/t/flows-are-gone-and-must-be-imported-again/27448/6 "2020-05-29T14:29:18Z")

</div>

Did the name of the pi change ? If so it may be looking for a different flows\_{your\_pi\_hostname}.json file...

---

<div class="post-metadata">

### Author: ![mdd](https://avatars.discourse-cdn.com/v4/letter/m/43a26b/32.png) [@mdd](https://discourse.nodered.org/u/mdd)
#### Post date: [29 May 2020 15:28 UTC](https://discourse.nodered.org/t/flows-are-gone-and-must-be-imported-again/27448/7 "2020-05-29T15:28:00Z")

</div>

I have not changed the hostname. If I uninstall nodered, then the flow and cred.json have the same name (Flow\_hostname\_.json). Under ./node-red there are only these two files with the name ... if I look into the flow\_hostname\_.json contain all my flows there. I now create a clean backup from the Raspi a few days ago and then post the log file with: node-red-stop / node-red-start

---

<div class="post-metadata">

### Author: ![mdd](https://avatars.discourse-cdn.com/v4/letter/m/43a26b/32.png) [@mdd](https://discourse.nodered.org/u/mdd)
#### Post date: [29 May 2020 17:25 UTC](https://discourse.nodered.org/t/flows-are-gone-and-must-be-imported-again/27448/8 "2020-05-29T17:25:30Z")

</div>

I have restored a complete backup.  
Then node-red-stop ... start. Get no connection to the editor http: // xxxxx: 1880.  
##########################################################  
p Node-RED

Use node-red-start to start Node-RED again

pi@rasp\_ffmi2:~ $ node-red-start

Start Node-RED

Once Node-RED has started, point a browser at [http://xxx.xxx.xxx.xxx:1880](http://xxx.xxx.xxx.xxx:1880)  
On Pi Node-RED works better with the Firefox or Chrome browser

Use node-red-stop to stop Node-RED  
Use node-red-start to start Node-RED again  
Use node-red-log to view the recent log output  
Use sudo systemctl enable nodered.service to autostart Node-RED at every boot  
Use sudo systemctl disable nodered.service to disable autostart on boot

To find more nodes and example flows - go to [http://flows.nodered.org](http://flows.nodered.org)

# Starting as a systemd service. Started Node-RED graphical event wiring tool. 29 May 18:09:16 - [info] Willkommen bei Node-RED!

## 29 May 18:09:16 - [info] Node-RED Version: v1.0.6 29 May 18:09:16 - [info] Node.js Version: v10.20.1 29 May 18:09:16 - [info] Linux 4.19.75-v7+ arm LE 29 May 18:09:17 - [info] Paletten-Nodes werden geladen 29 May 18:09:22 - [info] Dashboard version 2.21.0 started at /ui 29 May 18:09:24 - [info] Einstellungsdatei: /home/pi/.node-red/settings.js 29 May 18:09:24 - [info] Kontextspeicher: 'default' [module=memory] 29 May 18:09:24 - [info] Benutzerverzeichnis: /home/pi/.node-red 29 May 18:09:24 - [warn] Projekte inaktiviert: editorTheme.projects.enabled=false 29 May 18:09:24 - [info] Flow-Datei: /home/pi/.node-red/flows\_rasp\_ffmi2.json 29 May 18:09:24 - [info] Server wird jetzt auf [http://127.0.0.1:1880/](http://127.0.0.1:1880/) ausgeführt. 29 May 18:09:24 - [warn]

## Die Datei mit den Datenflowberechtigungsnachweisen wird mit einem vom System generierten Schlüssel verschlüsselt. Wenn der vom System generierte Schlüssel aus irgendeinem Grund verloren geht, werden Ihre Berechtigungsnachweise Die Datei kann nicht wiederhergestellt werden. Sie müssen sie löschen und erneut eingeben. Ihre Berechtigungsnachweise. Sie sollten Ihren eigenen Schlüssel mit Hilfe der Option 'credentialSecret' in Ihre Einstellungsdatei. Node-RED wird dann Ihre Berechtigungsnachweise erneut verschlüsseln. Datei mit dem ausgewählten Schlüssel beim nächsten Deployen einer Änderung verwenden.

# 29 May 18:09:24 - [info] Flows starten 29 May 18:09:25 - [info] Flows gestartet 29 May 18:09:25 - [warn] [node-hue-bridge:35344288.bed9ae] connect ECONNREFUSED 127.0.0.1:80 29 May 18:09:25 - [info] [mqtt-broker:IP] Verbindung zum Broker mqtt://localhost:1883 hergestellt. 29 May 18:09:25 - [info] [mqtt-broker:unixweb] Verbindung zum Broker mqtt://mqtt.unixweb.de:1883 hergestellt. 29 May 18:09:26 - [red] Uncaught Exception: 29 May 18:09:26 - Api Error: Unexpected response status; 404 at requireStatusCode200 (/home/pi/.node-red/node\_modules/node-hue-api/hue-api/httpPromise.js:100:15) at \_fulfilled (/home/pi/.node-red/node\_modules/q/q.js:787:54) at /home/pi/.node-red/node\_modules/q/q.js:816:30 at Promise.promise.promiseDispatch (/home/pi/.node-red/node\_modules/q/q.js:749:13) at /home/pi/.node-red/node\_modules/q/q.js:557:44 nodered.service: Main process exited, code=exited, status=1/FAILURE nodered.service: Unit entered failed state. nodered.service: Failed with result 'exit-code'. nodered.service: Service hold-off time over, scheduling restart. Stopped Node-RED graphical event wiring tool. Started Node-RED graphical event wiring tool. 29 May 18:09:28 - [info] Willkommen bei Node-RED!

## 29 May 18:09:28 - [info] Node-RED Version: v1.0.6 29 May 18:09:28 - [info] Node.js Version: v10.20.1 29 May 18:09:28 - [info] Linux 4.19.75-v7+ arm LE 29 May 18:09:29 - [info] Paletten-Nodes werden geladen 29 May 18:09:34 - [info] Dashboard version 2.21.0 started at /ui 29 May 18:09:35 - [info] Einstellungsdatei: /home/pi/.node-red/settings.js 29 May 18:09:35 - [info] Kontextspeicher: 'default' [module=memory] 29 May 18:09:35 - [info] Benutzerverzeichnis: /home/pi/.node-red 29 May 18:09:35 - [warn] Projekte inaktiviert: editorTheme.projects.enabled=false 29 May 18:09:35 - [info] Flow-Datei: /home/pi/.node-red/flows\_rasp\_ffmi2.json 29 May 18:09:35 - [info] Server wird jetzt auf [http://127.0.0.1:1880/](http://127.0.0.1:1880/) ausgeführt. 29 May 18:09:35 - [warn]

## Die Datei mit den Datenflowberechtigungsnachweisen wird mit einem vom System generierten Schlüssel verschlüsselt. Wenn der vom System generierte Schlüssel aus irgendeinem Grund verloren geht, werden Ihre Berechtigungsnachweise Die Datei kann nicht wiederhergestellt werden. Sie müssen sie löschen und erneut eingeben. Ihre Berechtigungsnachweise. Sie sollten Ihren eigenen Schlüssel mit Hilfe der Option 'credentialSecret' in Ihre Einstellungsdatei. Node-RED wird dann Ihre Berechtigungsnachweise erneut verschlüsseln. Datei mit dem ausgewählten Schlüssel beim nächsten Deployen einer Änderung verwenden.

# 29 May 18:09:36 - [info] Flows starten 29 May 18:09:37 - [info] Flows gestartet 29 May 18:09:37 - [warn] [node-hue-bridge:35344288.bed9ae] connect ECONNREFUSED 127.0.0.1:80 29 May 18:09:37 - [info] [mqtt-broker:IP] Verbindung zum Broker mqtt://localhost:1883 hergestellt. 29 May 18:09:38 - [red] Uncaught Exception: 29 May 18:09:38 - Api Error: Unexpected response status; 404 at requireStatusCode200 (/home/pi/.node-red/node\_modules/node-hue-api/hue-api/httpPromise.js:100:15) at \_fulfilled (/home/pi/.node-red/node\_modules/q/q.js:787:54) at /home/pi/.node-red/node\_modules/q/q.js:816:30 at Promise.promise.promiseDispatch (/home/pi/.node-red/node\_modules/q/q.js:749:13) nodered.service: Main process exited, code=exited, status=1/FAILURE nodered.service: Unit entered failed state. nodered.service: Failed with result 'exit-code'. nodered.service: Service hold-off time over, scheduling restart. Stopped Node-RED graphical event wiring tool. Started Node-RED graphical event wiring tool. 29 May 18:09:40 - [info] Willkommen bei Node-RED!

## 29 May 18:09:40 - [info] Node-RED Version: v1.0.6 29 May 18:09:40 - [info] Node.js Version: v10.20.1 29 May 18:09:40 - [info] Linux 4.19.75-v7+ arm LE 29 May 18:09:41 - [info] Paletten-Nodes werden geladen 29 May 18:09:45 - [info] Dashboard version 2.21.0 started at /ui 29 May 18:09:47 - [info] Einstellungsdatei: /home/pi/.node-red/settings.js 29 May 18:09:47 - [info] Kontextspeicher: 'default' [module=memory] 29 May 18:09:47 - [info] Benutzerverzeichnis: /home/pi/.node-red 29 May 18:09:47 - [warn] Projekte inaktiviert: editorTheme.projects.enabled=false 29 May 18:09:47 - [info] Flow-Datei: /home/pi/.node-red/flows\_rasp\_ffmi2.json 29 May 18:09:47 - [info] Server wird jetzt auf [http://127.0.0.1:1880/](http://127.0.0.1:1880/) ausgeführt. 29 May 18:09:47 - [warn]

## Die Datei mit den Datenflowberechtigungsnachweisen wird mit einem vom System generierten Schlüssel verschlüsselt. Wenn der vom System generierte Schlüssel aus irgendeinem Grund verloren geht, werden Ihre Berechtigungsnachweise Die Datei kann nicht wiederhergestellt werden. Sie müssen sie löschen und erneut eingeben. Ihre Berechtigungsnachweise. Sie sollten Ihren eigenen Schlüssel mit Hilfe der Option 'credentialSecret' in Ihre Einstellungsdatei. Node-RED wird dann Ihre Berechtigungsnachweise erneut verschlüsseln. Datei mit dem ausgewählten Schlüssel beim nächsten Deployen einer Änderung verwenden.

# 29 May 18:09:47 - [info] Flows starten 29 May 18:09:48 - [info] Flows gestartet 29 May 18:09:48 - [warn] [node-hue-bridge:35344288.bed9ae] connect ECONNREFUSED 127.0.0.1:80 29 May 18:09:48 - [info] [mqtt-broker:IP] Verbindung zum Broker mqtt://localhost:1883 hergestellt. 29 May 18:09:48 - [red] Uncaught Exception: 29 May 18:09:48 - Api Error: Unexpected response status; 404 at requireStatusCode200 (/home/pi/.node-red/node\_modules/node-hue-api/hue-api/httpPromise.js:100:15) at \_fulfilled (/home/pi/.node-red/node\_modules/q/q.js:787:54) nodered.service: Main process exited, code=exited, status=1/FAILURE nodered.service: Unit entered failed state. nodered.service: Failed with result 'exit-code'. nodered.service: Service hold-off time over, scheduling restart. Stopped Node-RED graphical event wiring tool. Started Node-RED graphical event wiring tool. 29 May 18:09:51 - [info] Willkommen bei Node-RED!

29 May 18:09:51 - [info] Node-RED Version: v1.0.6  
29 May 18:09:51 - [info] Node.js Version: v10.20.1  
29 May 18:09:51 - [info] Linux 4.19.75-v7+ arm LE  
^C  
##############################################  
pi@rasp\_ffmi2:~ $ sudo systemctl status nodered  
● nodered.service - Node-RED graphical event wiring tool  
Loaded: loaded (/lib/systemd/system/nodered.service; enabled; vendor preset:  
Active: active (running) since Fri 2020-05-29 18:15:33 CEST; 3s ago  
Docs: [http://nodered.org/docs/hardware/raspberrypi.html](http://nodered.org/docs/hardware/raspberrypi.html)  
Main PID: 3852 (node)  
Tasks: 11 (limit: 4915)  
CGroup: /system.slice/nodered.service  
└─3852 node --max\_old\_space\_size=256 /usr/lib/node\_modules/node-red/b

Mai 29 18:15:33 rasp\_ffmi2 systemd[1]: Started Node-RED graphical event wiring t  
Mai 29 18:15:35 rasp\_ffmi2 Node-RED[3852]: 29 May 18:15:35 - [info]  
Mai 29 18:15:35 rasp\_ffmi2 Node-RED[3852]: Willkommen bei Node-RED!  
Mai 29 18:15:35 rasp\_ffmi2 Node-RED[3852]: ===================  
Mai 29 18:15:35 rasp\_ffmi2 Node-RED[3852]: 29 May 18:15:35 - [info] Node-RED Ver  
Mai 29 18:15:35 rasp\_ffmi2 Node-RED[3852]: 29 May 18:15:35 - [info] Node.js Ver  
Mai 29 18:15:35 rasp\_ffmi2 Node-RED[3852]: 29 May 18:15:35 - [info] Linux 4.19.7  
Mai 29 18:15:37 rasp\_ffmi2 Node-RED[3852]: 29 May 18:15:37 - [info] Paletten-Nod  
lines 1-17/17 (END)  
###########################################################  
then 2nd try. I stop the service and restart.

pi@rasp\_ffmi2:~ sudo systemctl disable nodered.service Removed /etc/systemd/system/multi-user.target.wants/nodered.service. pi@rasp\_ffmi2:~ node-red-stop

Stop Node-RED

Use node-red-start to start Node-RED again  
^[[A  
pi@rasp\_ffmi2:~ $ node-red-start

Start Node-RED

Once Node-RED has started, point a browser at [http://xxx.xxx.xxx.xxx:1880](http://xxx.xxx.xxx.xxx:1880)  
On Pi Node-RED works better with the Firefox or Chrome browser

Use node-red-stop to stop Node-RED  
Use node-red-start to start Node-RED again  
Use node-red-log to view the recent log output  
Use sudo systemctl enable nodered.service to autostart Node-RED at every boot  
Use sudo systemctl disable nodered.service to disable autostart on boot

To find more nodes and example flows - go to [http://flows.nodered.org](http://flows.nodered.org)

# Starting as a systemd service. Started Node-RED graphical event wiring tool. 29 May 18:17:20 - [info] Willkommen bei Node-RED!

## 29 May 18:17:20 - [info] Node-RED Version: v1.0.6 29 May 18:17:20 - [info] Node.js Version: v10.20.1 29 May 18:17:20 - [info] Linux 4.19.75-v7+ arm LE 29 May 18:17:21 - [info] Paletten-Nodes werden geladen 29 May 18:17:26 - [info] Dashboard version 2.21.0 started at /ui 29 May 18:17:27 - [info] Einstellungsdatei: /home/pi/.node-red/settings.js 29 May 18:17:27 - [info] Kontextspeicher: 'default' [module=memory] 29 May 18:17:27 - [info] Benutzerverzeichnis: /home/pi/.node-red 29 May 18:17:27 - [warn] Projekte inaktiviert: editorTheme.projects.enabled=false 29 May 18:17:27 - [info] Flow-Datei: /home/pi/.node-red/flows\_rasp\_ffmi2.json 29 May 18:17:28 - [info] Server wird jetzt auf [http://127.0.0.1:1880/](http://127.0.0.1:1880/) ausgeführt. 29 May 18:17:28 - [warn]

## Die Datei mit den Datenflowberechtigungsnachweisen wird mit einem vom System generierten Schlüssel verschlüsselt. Wenn der vom System generierte Schlüssel aus irgendeinem Grund verloren geht, werden Ihre Berechtigungsnachweise Die Datei kann nicht wiederhergestellt werden. Sie müssen sie löschen und erneut eingeben. Ihre Berechtigungsnachweise. Sie sollten Ihren eigenen Schlüssel mit Hilfe der Option 'credentialSecret' in Ihre Einstellungsdatei. Node-RED wird dann Ihre Berechtigungsnachweise erneut verschlüsseln. Datei mit dem ausgewählten Schlüssel beim nächsten Deployen einer Änderung verwenden.

# 29 May 18:17:28 - [info] Flows starten 29 May 18:17:29 - [info] Flows gestartet 29 May 18:17:29 - [warn] [node-hue-bridge:35344288.bed9ae] connect ECONNREFUSED 127.0.0.1:80 29 May 18:17:29 - [info] [mqtt-broker:IP] Verbindung zum Broker mqtt://localhost:1883 hergestellt. 29 May 18:17:29 - [info] [mqtt-broker:unixweb] Verbindung zum Broker mqtt://mqtt.unixweb.de:1883 hergestellt. 29 May 18:17:29 - [red] Uncaught Exception: 29 May 18:17:29 - Api Error: Unexpected response status; 404 at requireStatusCode200 (/home/pi/.node-red/node\_modules/node-hue-api/hue-api/httpPromise.js:100:15) at \_fulfilled (/home/pi/.node-red/node\_modules/q/q.js:787:54) at /home/pi/.node-red/node\_modules/q/q.js:816:30 nodered.service: Main process exited, code=exited, status=1/FAILURE nodered.service: Unit entered failed state. nodered.service: Failed with result 'exit-code'. nodered.service: Service hold-off time over, scheduling restart. Stopped Node-RED graphical event wiring tool. Started Node-RED graphical event wiring tool. 29 May 18:17:32 - [info] Willkommen bei Node-RED!

## 29 May 18:17:32 - [info] Node-RED Version: v1.0.6 29 May 18:17:32 - [info] Node.js Version: v10.20.1 29 May 18:17:32 - [info] Linux 4.19.75-v7+ arm LE 29 May 18:17:33 - [info] Paletten-Nodes werden geladen 29 May 18:17:38 - [info] Dashboard version 2.21.0 started at /ui 29 May 18:17:40 - [info] Einstellungsdatei: /home/pi/.node-red/settings.js 29 May 18:17:40 - [info] Kontextspeicher: 'default' [module=memory] 29 May 18:17:40 - [info] Benutzerverzeichnis: /home/pi/.node-red 29 May 18:17:40 - [warn] Projekte inaktiviert: editorTheme.projects.enabled=false 29 May 18:17:40 - [info] Flow-Datei: /home/pi/.node-red/flows\_rasp\_ffmi2.json 29 May 18:17:40 - [info] Server wird jetzt auf [http://127.0.0.1:1880/](http://127.0.0.1:1880/) ausgeführt. 29 May 18:17:40 - [warn]

## Die Datei mit den Datenflowberechtigungsnachweisen wird mit einem vom System generierten Schlüssel verschlüsselt. Wenn der vom System generierte Schlüssel aus irgendeinem Grund verloren geht, werden Ihre Berechtigungsnachweise Die Datei kann nicht wiederhergestellt werden. Sie müssen sie löschen und erneut eingeben. Ihre Berechtigungsnachweise. Sie sollten Ihren eigenen Schlüssel mit Hilfe der Option 'credentialSecret' in Ihre Einstellungsdatei. Node-RED wird dann Ihre Berechtigungsnachweise erneut verschlüsseln. Datei mit dem ausgewählten Schlüssel beim nächsten Deployen einer Änderung verwenden.

# 29 May 18:17:40 - [info] Flows starten 29 May 18:17:41 - [info] Flows gestartet 29 May 18:17:42 - [warn] [node-hue-bridge:35344288.bed9ae] connect ECONNREFUSED 127.0.0.1:80 29 May 18:17:42 - [info] [mqtt-broker:IP] Verbindung zum Broker mqtt://localhost:1883 hergestellt. 29 May 18:17:42 - [red] Uncaught Exception: 29 May 18:17:42 - Api Error: Unexpected response status; 404 at requireStatusCode200 (/home/pi/.node-red/node\_modules/node-hue-api/hue-api/httpPromise.js:100:15) nodered.service: Main process exited, code=exited, status=1/FAILURE nodered.service: Unit entered failed state. nodered.service: Failed with result 'exit-code'. nodered.service: Service hold-off time over, scheduling restart. Stopped Node-RED graphical event wiring tool. Started Node-RED graphical event wiring tool. 29 May 18:17:44 - [info] Willkommen bei Node-RED!

29 May 18:17:44 - [info] Node-RED Version: v1.0.6  
29 May 18:17:44 - [info] Node.js Version: v10.20.1  
29 May 18:17:44 - [info] Linux 4.19.75-v7+ arm LE  
29 May 18:17:45 - [info] Paletten-Nodes werden geladen  
^C  
pi@rasp\_ffmi2:~ $

---

<div class="post-metadata">

### Author: ![mdd](https://avatars.discourse-cdn.com/v4/letter/m/43a26b/32.png) [@mdd](https://discourse.nodered.org/u/mdd)
#### Post date: [29 May 2020 18:11 UTC](https://discourse.nodered.org/t/flows-are-gone-and-must-be-imported-again/27448/9 "2020-05-29T18:11:59Z")

</div>

Hello and hurry, hurry thanks. You brought me to the solution.

The flow with the HUE led to a crash.  
The solution was here: [Trouble starting node red on Raspberry pi](https://discourse.nodered.org/t/trouble-starting-node-red-on-raspberry-pi/27341/2)

It works!! All flows are there ... Editor works and so does the UI

---

<div class="post-metadata">

### Author: ![Colin](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/colin/32/17040_2.png) [@Colin](https://discourse.nodered.org/u/Colin)
#### Post date: [29 May 2020 18:46 UTC](https://discourse.nodered.org/t/flows-are-gone-and-must-be-imported-again/27448/10 "2020-05-29T18:46:48Z")

</div>

I am a bit confused. What exactly did you mean when you said the flows were gone? I assumed that you meant that when you opened the editor it opened ok but with empty flows.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)
#### Post date: [28 July 2020 18:46 UTC](https://discourse.nodered.org/t/flows-are-gone-and-must-be-imported-again/27448/11 "2020-07-28T18:46:51Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
