Help with HPE Invalid header token


I'm moving my first steps with NR (as Home assistant integration) and I'm having my first issue...

I'trying to send this simple http request:
to a Lan web server, and I'm getting this error:
"RequestError: Parse Error: Invalid header value char.
If I copy/paste the same URL on Chrome it just works.
I'not black belt in headers but checking the server header I cannot see a suspicious char.
Is there anything I can do to bypass such a strict header check?

Thank you!

Welcome to the forum @Percent

That is very strange. The only other reference to that error that I can find in the forum is this post which was posted just yesterday.

I am currently experiencing this issue as well and have played endlessly with my configurations. I tried encoding the URL, setting the headers and other settings within the function node, and selecting the 'Disable strict HTTP parsing' check box all without success. The most misleading part is that the request works perfectly fine in Postman.

If I find any result I will comment back here.

Just to clarify, @gettmad's issue is not a third case, it is the one I already linked to.

1 Like

Thanks, I hope we can find something to bypass the error as it seems it's only occurring with node red.


Please see my latest comment on the following post:
Using HTTP Request to pull data from FANUC Web Sever

Further, to install the beta you can invoke the following command in the command line window:

npm install -g --unsafe-perm node-red@next

I hope this solves your issue as it solved mine.

Best of luck.

Thanks gettmad!!
I think I'll wait for the stable release, but I'm happy to see it worked for you!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.