# Home Assistant - Errors Node Red new install seems to start but errors and shuts down

**URL:** https://discourse.nodered.org/t/home-assistant-errors-node-red-new-install-seems-to-start-but-errors-and-shuts-down/74524
**Category:** General
**Tags:** home-assistant
**Created:** [1 February 2023 01:14 UTC](https://discourse.nodered.org/t/home-assistant-errors-node-red-new-install-seems-to-start-but-errors-and-shuts-down/74524 "2023-02-01T01:14:38Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![glwalt](https://avatars.discourse-cdn.com/v4/letter/g/779978/32.png) [@glwalt](https://discourse.nodered.org/u/glwalt)
#### Post date: [1 February 2023 01:14 UTC](https://discourse.nodered.org/t/home-assistant-errors-node-red-new-install-seems-to-start-but-errors-and-shuts-down/74524/1 "2023-02-01T01:14:38Z")

</div>

## s6-rc: info: service s6rc-oneshot-runner: starting s6-rc: info: service s6rc-oneshot-runner successfully started s6-rc: info: service base-addon-banner: starting

## Add-on: Node-RED Flow-based programming for the Internet of Things

## Add-on version: 14.0.2 You are running the latest version of this add-on. System: Home Assistant OS 9.5 (aarch64 / raspberrypi4-64) Home Assistant Core: 2023.1.7 Home Assistant Supervisor: 2023.01.1

## Please, share the above information when looking for help or support in, e.g., GitHub, forums or the Discord chat.

s6-rc: info: service base-addon-banner successfully started  
s6-rc: info: service fix-attrs: starting  
s6-rc: info: service base-addon-log-level: starting  
s6-rc: info: service fix-attrs successfully started  
s6-rc: info: service base-addon-log-level successfully started  
s6-rc: info: service legacy-cont-init: starting  
s6-rc: info: service legacy-cont-init successfully started  
s6-rc: info: service init-nginx: starting  
s6-rc: info: service init-customizations: starting  
s6-rc: info: service init-customizations successfully started  
s6-rc: info: service init-nodered: starting  
[20:06:27] FATAL:  
[20:06:27] FATAL: Configuration of this add-on is incomplete.  
[20:06:27] FATAL:  
[20:06:27] FATAL: Please be sure to set the "credential\_secret" option.  
[20:06:27] FATAL:  
[20:06:27] FATAL: The credential secret is an encryption token, much like  
[20:06:27] FATAL: a password, that is used by Node-RED for encrypting  
[20:06:27] FATAL: credentials you put into Node-RED.  
[20:06:27] FATAL:  
[20:06:27] FATAL: Just like a password, a credential secret can be  
[20:06:27] FATAL: anything you like. Just be sure to store it somewhere  
[20:06:27] FATAL: safe for later, e.g., in case of a recovery.  
[20:06:27] FATAL:  
s6-rc: warning: unable to start service init-nodered: command exited 1  
[20:06:27] FATAL:  
[20:06:27] FATAL: SSL has been enabled using the 'ssl' option,  
[20:06:27] FATAL: this requires a SSL certificate file which is  
[20:06:27] FATAL: configured using the 'certfile' option in the  
[20:06:27] FATAL: add-on configuration.  
[20:06:27] FATAL:  
[20:06:27] FATAL: Unfortunately, the file specified in the  
[20:06:27] FATAL: 'certfile' option does not exists.  
[20:06:27] FATAL:  
[20:06:27] FATAL: Please ensure the certificate file exists and  
[20:06:27] FATAL: is placed in the '/ssl/' directory.  
[20:06:27] FATAL:  
[20:06:27] FATAL: In case you don't have SSL yet, consider getting  
[20:06:27] FATAL: a SSL certificate or setting the 'ssl' option  
[20:06:27] FATAL: to 'false' in case you are not planning on using  
[20:06:27] FATAL: SSL with this add-on.  
[20:06:27] FATAL:  
[20:06:27] FATAL: Check the add-on manual for more information.  
[20:06:27] FATAL:  
s6-rc: warning: unable to start service init-nginx: command exited 1  
/run/s6/basedir/scripts/rc.init: warning: s6-rc failed to properly bring all the services up! Check your logs (in /run/uncaught-logs/current if you have in-container logging) for more information.  
/run/s6/basedir/scripts/rc.init: fatal: stopping the container.  
s6-rc: info: service init-customizations: stopping  
s6-rc: info: service init-customizations successfully stopped  
s6-rc: info: service legacy-cont-init: stopping  
s6-rc: info: service legacy-cont-init successfully stopped  
s6-rc: info: service fix-attrs: stopping  
s6-rc: info: service base-addon-log-level: stopping  
s6-rc: info: service fix-attrs successfully stopped  
s6-rc: info: service base-addon-log-level successfully stopped  
s6-rc: info: service base-addon-banner: stopping  
s6-rc: info: service base-addon-banner successfully stopped  
s6-rc: info: service s6rc-oneshot-runner: stopping  
s6-rc: info: service s6rc-oneshot-runner successfully stopped

---

<div class="post-metadata">

### Author: ![TotallyInformation](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/totallyinformation/32/31_2.png) [@TotallyInformation](https://discourse.nodered.org/u/TotallyInformation)
#### Post date: [1 February 2023 01:29 UTC](https://discourse.nodered.org/t/home-assistant-errors-node-red-new-install-seems-to-start-but-errors-and-shuts-down/74524/2 "2023-02-01T01:29:29Z")

</div>

Sorry, looks like a Home Assistant issue, not a node-red one. You'll need to ask on their forum.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)
#### Post date: [2 April 2023 01:30 UTC](https://discourse.nodered.org/t/home-assistant-errors-node-red-new-install-seems-to-start-but-errors-and-shuts-down/74524/3 "2023-04-02T01:30:21Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
