# How to not have to manually refresh a dashboard ui on startup

**URL:** <https://discourse.nodered.org/t/how-to-not-have-to-manually-refresh-a-dashboard-ui-on-startup/29233>\
**Category:** Dashboard\
**Created:** [30 June 2020 13:35 UTC](https://discourse.nodered.org/t/how-to-not-have-to-manually-refresh-a-dashboard-ui-on-startup/29233 "2020-06-30T13:35:00Z")\
**Posts on this page:** 1\
**Showing post:** 6

<div class="post-metadata">

**Author:** ![Andrei](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/andrei/32/10446_2.png) [@Andrei](https://discourse.nodered.org/u/Andrei)\
**Post date:** [30 June 2020 14:35 UTC](https://discourse.nodered.org/t/how-to-not-have-to-manually-refresh-a-dashboard-ui-on-startup/29233/6 "2020-06-30T14:35:09Z")

</div>

Your Node-RED instance is installed in the very same Raspberry Pi where you are trying to run the dashboard ? Perhaps Node-RED is installed in another machine ?

I can not imagine why your are getting those warnings.  
There are a couple of similar posts in the forum, like this one. Perhaps you can get some clue by reading those posts.

> [@Added the Ikea dimmer to the nodes](https://discourse.nodered.org/t/added-the-ikea-dimmer-to-the-nodes/22167):
>
> As new to Red Node when finally got it all up and running and one tutorial I then added the dimmer switch node, now all's just blank with 127.0.0.1 refused to connect. Try: Checking the connection Checking the proxy and the firewall ERR\_CONNECTION\_REFUSED well i've done all that, surely it cant be a reinstall

---

_[View the full topic](https://discourse.nodered.org/t/how-to-not-have-to-manually-refresh-a-dashboard-ui-on-startup/29233)._
