Major Issue updating Node and Node Red


#21

i know this is not strictly node-red related, but as it happens while installing nodejs from stock node repositories, sometimes, i'm just asking what's happening globally to these repositories, both of ubuntu and debian...


#22

[Edited]
@dynamicdave, The reason for failure should be in the node red log. Run node-red-log in a terminal to see it, however I don't think this is relevant to this thread, you might be better starting a new one.


#24

I've given up trying to sort this out and re-flashed the RPi-3 mirco SD card.
I've installed all the nodes I was using but can't sort out this one. sqlite
I get this error message. And yes when I go to the directory it is empty.
i.e. node_sqlite3.node is missing

12 Jul 15:45:23 - [warn] [node-red-node-sqlite/sqlite] Error: Cannot find module '/home/pi/.node-red/node_modules/sqlite3/lib/binding/node-v57-linux-arm/node_sqlite3.node' (line:4)

Any advice would be appreciated.


#25

I think you need to install sqlite separately
sudo apt-get install sqlite3

opening a new thread about sqlite


#26

I haven't tried to upgrade yet, but...
I do make a copy of the SD card from time to time. In other projects it's saved me loads of hours. I screw up so often that I never start a significant operation without a very recent backup SD card.

You need an SD card with Raspian OS on it.
You need an HDMI display.
Remove the SD with Home Assistant on it. (Mark it "HA" so that you don't mix it up and accidentally write over it).
Insert the Raspian SD card and boot the Pi.
Insert the "HA" SD card into a USB adapter, then plug it into the Pi. (It will likely mount as /dev/sda*)
Insert a new "Backup" SD card into another USB adapter, then plug it into the Pi. (It will likely mount as /dev/sdb
Under "Accessories" select the "Copy SD card" option.
Then copy sda to sdb.

Now, if I brick my HA installation, I just follow the above procedure to copy my backup back to the "HA" SD card.

Hope this helps....
Steve Mann

EDIT

Whoops, right answer, wrong forum....:thinking:

But I'll leave it up since the copy procedure still works.
Steve


#27

This solution WORKED for me:

If that fails then delete
/etc/apt/sources.list.d/nodesource.list
And then re-run

Install Node.js LTS :heavy_check_mark: Node v8.11.3 Npm 5.6.0