# Mysql - "Pool closed" error

**URL:** https://discourse.nodered.org/t/mysql-pool-closed-error/41168
**Category:** General
**Created:** [17 February 2021 14:57 UTC](https://discourse.nodered.org/t/mysql-pool-closed-error/41168 "2021-02-17T14:57:14Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![stefandersen](https://avatars.discourse-cdn.com/v4/letter/s/9de053/32.png) [@stefandersen](https://discourse.nodered.org/u/stefandersen)
#### Post date: [17 February 2021 14:57 UTC](https://discourse.nodered.org/t/mysql-pool-closed-error/41168/1 "2021-02-17T14:57:14Z")

</div>

I have a Node RED app running on IBM cloud and are using the “node-red-node-mysql” to make queries to a MySql server running on a Windows Server VM in Azure cloud. For long periods of time it works fine, but then at irregular intervals, I get the “pool closed” error on the MySql node.  
What is the reason for this error and what kind of steps can I make to avoid this from happening?

---

<div class="post-metadata">

### Author: ![Ashfaak](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/ashfaak/32/34409_2.png) [@Ashfaak](https://discourse.nodered.org/u/Ashfaak)
#### Post date: [1 March 2021 12:13 UTC](https://discourse.nodered.org/t/mysql-pool-closed-error/41168/2 "2021-03-01T12:13:33Z")

</div>

Hi @stefandersen

I have this same issue. It happens when the DB is inaccessible for some reason. Unfortunately I cannot catch the error using the Catch node, so have not been able to deal with it within NR. It seems the error is produced by the mysql configuration rather than the mysql node itself.

Regards

Ashfaak

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)
#### Post date: [30 April 2021 12:14 UTC](https://discourse.nodered.org/t/mysql-pool-closed-error/41168/3 "2021-04-30T12:14:18Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
