# Node-RED 3.0.2 on Elastic Beanstalk : 413 "Request entity too large" error on palette deploy

**URL:** <https://discourse.nodered.org/t/node-red-3-0-2-on-elastic-beanstalk-413-request-entity-too-large-error-on-palette-deploy/69352>\
**Category:** General\
**Created:** [21 October 2022 00:39 UTC](https://discourse.nodered.org/t/node-red-3-0-2-on-elastic-beanstalk-413-request-entity-too-large-error-on-palette-deploy/69352 "2022-10-21T00:39:20Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![nicholas](https://avatars.discourse-cdn.com/v4/letter/n/4da419/32.png) [@nicholas](https://discourse.nodered.org/u/nicholas)\
**Post date:** [21 October 2022 00:39 UTC](https://discourse.nodered.org/t/node-red-3-0-2-on-elastic-beanstalk-413-request-entity-too-large-error-on-palette-deploy/69352/1 "2022-10-21T00:39:20Z")

</div>

I'm running Node-RED 3.0.2 on an Elastic Beanstalk environment (Amazon Linux 2 / Node 16)

After adding a fair amount of flows, I began to encounter deploy failures in the admin palette with error  
**"413 : Request entity too large"**

At first, this error only appeared when deploying a large number of nodes; now it appears when deploying only a dozen or so.

I made sure that the deploy button is set to "only changed nodes"

I have read the below thread on a similar topic:

> [@Request entity too large 413](https://discourse.nodered.org/t/request-entity-too-large-413/2397/4):
>
> Yes, as I said, that was broken until the 0.19 release. If you moved the admin handler, then the parser attached to the node root would get first look at the request - and that parser does not honour apiMaxLength.

and adjusted  
apiMaxLength  
in settings.js accordingly, **however** this did not fix the problem;

in addition, I'm not sure where to put the additional suggested lines:

```auto
app.use(bodyParser.json({limit: '50mb'}));
app.use(bodyParser.urlencoded({limit: '50mb', extended: true}));

```

(I don't think it's in settings.js because I can't find the "RED.init" line referenced in that thead, in the settings.js file,  
and since configurations added to the underlying EC2 instance don't survive Beanstalk replacement, I figure it can't be in the instance's /var/app files

**How can I prevent this 413 error and make flow / node deploys from the palette successful?**

All guidance is much appreciated!

// EDIT : I just spotted this in the logs, adjacent to the 413 errors:  
`*188 a client request body is buffered to a temporary file`

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)\
**Post date:** [20 December 2022 00:39 UTC](https://discourse.nodered.org/t/node-red-3-0-2-on-elastic-beanstalk-413-request-entity-too-large-error-on-palette-deploy/69352/2 "2022-12-20T00:39:34Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
