# Node-red-contrib-mssql-plus-0.12.2 - Failed to connect

**URL:** https://discourse.nodered.org/t/node-red-contrib-mssql-plus-0-12-2-failed-to-connect/96625
**Category:** General
**Created:** [17 April 2025 16:33 UTC](https://discourse.nodered.org/t/node-red-contrib-mssql-plus-0-12-2-failed-to-connect/96625 "2025-04-17T16:33:06Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![jumpier](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/jumpier/32/44058_2.png) [@jumpier](https://discourse.nodered.org/u/jumpier)
#### Post date: [17 April 2025 16:33 UTC](https://discourse.nodered.org/t/node-red-contrib-mssql-plus-0-12-2-failed-to-connect/96625/1 "2025-04-17T16:33:06Z")

</div>

Hi to everybody

i've try to open connection with local DB SQL Server Express Edition v2019 (the SQL Server is installed on the same computer where i execute Node-Red).

I've download and install a node-red-contrib-mssql-plus-0.12.2; then i try to the DB configure connection.

The server name are "NODE-RED\SQLEXPRESS", port 1433, table name "TblNodeRed". Then i've create a user: name and password equal to "nodered" (see the picuture).

The SQL firewall roules and port configuration may be ok (see the pictures).

Any idea? Thanks a lot

Error messages are show next to the first images

 ![errcon](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/3X/a/0/a02fc17133080d57ffad6402d36c60773f4118c0.png)  
 ![errcon1](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/3X/d/1/d1c5a3e8065c6b54ffbc4a67a6b943920c0d6da4.png)  
 ![firewall](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/3X/8/4/8417a036c1f8bc76c3af2cb5996126f7a8d215b8.png)  
 ![conf01](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/3X/1/f/1ffa8b13536951d0d1a8c0e78e06a026c9d80d7a.png)  
 ![conf02](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/3X/0/2/0224219df05f8042e7cf67da7802e89fe24b312f.png)  
 ![conf03](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/3X/f/5/f5e6f76eac5eda11b9e0ba73b70065035d85451a.png)  
 ![flow](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/3X/7/5/758e4311560f8dd16063c29c24582cdfaed2e4fa.png)

---

<div class="post-metadata">

### Author: ![Steve-Mcl](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/steve-mcl/32/4826_2.png) [@Steve-Mcl](https://discourse.nodered.org/u/Steve-Mcl)
#### Post date: [17 April 2025 16:59 UTC](https://discourse.nodered.org/t/node-red-contrib-mssql-plus-0-12-2-failed-to-connect/96625/2 "2025-04-17T16:59:43Z")

</div>

> [@jumpier](#):
>
> Any idea?

Yes. The SQL Express port is typically NOT 1433.

Check the instance logs to get the dynamically generated port number.

- [Problem connecting to mssql express · Issue #63 · bestlong/node-red-contrib-mssql-plus · GitHub](https://github.com/bestlong/node-red-contrib-mssql-plus/issues/63#issuecomment-1067390539)
- [similar threads](https://discourse.nodered.org/search?q=mssql%20instance%20%40steve-mcl%201433%20order%3Alatest) on forum

---

<div class="post-metadata">

### Author: ![Steve-Mcl](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/steve-mcl/32/4826_2.png) [@Steve-Mcl](https://discourse.nodered.org/u/Steve-Mcl)
#### Post date: [17 April 2025 18:38 UTC](https://discourse.nodered.org/t/node-red-contrib-mssql-plus-0-12-2-failed-to-connect/96625/3 "2025-04-17T18:38:13Z")

</div>

PS, just noticed you set the default port to 1433 so that might be ok (but still check SQL server logs)

More importantly, remove the instance name from the `Server` field. Also, instead of the DNS/WINS/HOST name, try using the IP of the machine running SQL Server. Something like `127.0.0.1` or `192.168.86.1.10` only.

Also, read the full threads I linked to (some valuable info in them).

---

<div class="post-metadata">

### Author: ![jumpier](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/jumpier/32/44058_2.png) [@jumpier](https://discourse.nodered.org/u/jumpier)
#### Post date: [17 April 2025 21:45 UTC](https://discourse.nodered.org/t/node-red-contrib-mssql-plus-0-12-2-failed-to-connect/96625/4 "2025-04-17T21:45:55Z")

</div>

> [@Steve-Mcl](#):
>
> More importantly, remove the instance name from the `Server` field. Also, instead of the DNS/WINS/HOST name, try using the IP of the machine running SQL Server. Something like `127.0.0.1` or `192.168.86.1.10` only.

Thank you Steve. I've change the server name from "NODE-RED\SQLEXPRESS" to "127.0.0.1" and now working fine

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)
#### Post date: [1 May 2025 21:46 UTC](https://discourse.nodered.org/t/node-red-contrib-mssql-plus-0-12-2-failed-to-connect/96625/5 "2025-05-01T21:46:43Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
