# Node-red crashes after "Started flows". Uncaught Exception : EADDRNOTAVAIL port 502

**URL:** <https://discourse.nodered.org/t/node-red-crashes-after-started-flows-uncaught-exception-eaddrnotavail-port-502/26478>\
**Category:** General\
**Created:** [11 May 2020 12:13 UTC](https://discourse.nodered.org/t/node-red-crashes-after-started-flows-uncaught-exception-eaddrnotavail-port-502/26478 "2020-05-11T12:13:02Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![kumarsemal](https://avatars.discourse-cdn.com/v4/letter/k/7feea3/32.png) [@kumarsemal](https://discourse.nodered.org/u/kumarsemal)\
**Post date:** [11 May 2020 12:13 UTC](https://discourse.nodered.org/t/node-red-crashes-after-started-flows-uncaught-exception-eaddrnotavail-port-502/26478/1 "2020-05-11T12:13:02Z")

</div>

I am unable to run node-red on my computer. This throws an error while starting NR. I uninstalled node.js and npm both and reinstalled again but the problem persists. Please tell me how to overcome this so that my node-red can run smoothly. Thanks in advance.  
11 May 17:35:12 - [info] Node-RED version: v1.0.6  
11 May 17:35:12 - [info] Node.js version: v12.16.3  
11 May 17:35:12 - [info] Windows\_NT 10.0.18362 ia32 LE  
11 May 17:35:13 - [info] Loading palette nodes  
11 May 17:35:14 - [info] Settings file : \Users\Win10.node-red\settings.js  
11 May 17:35:14 - [info] Context store : 'default' [module=memory]  
11 May 17:35:14 - [info] User directory : \Users\Win10.node-red  
11 May 17:35:14 - [warn] Projects disabled : editorTheme.projects.enabled=false  
11 May 17:35:14 - [info] Flows file : \Users\Win10.node-red\flows\_Win10-PC.json  
11 May 17:35:14 - [info] Server now running at [http://127.0.0.1:1880/](http://127.0.0.1:1880/)  
11 May 17:35:14 - [warn]

* * *

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials  
file will not be recoverable, you will have to delete it and re-enter  
your credentials.

## You should set your own key using the 'credentialSecret' option in your settings file. Node-RED will then re-encrypt your credentials file using your chosen key the next time you deploy a change.

11 May 17:35:14 - [info] Starting flows  
11 May 17:35:14 - [info] Started flows  
11 May 17:35:14 - [red] Uncaught Exception:  
11 May 17:35:14 - Error: listen EADDRNOTAVAIL: address not available 10.8.0.10:502  
at Server.setupListenHandle [as \_listen2] (net.js:1296:21)  
at listenInCluster (net.js:1361:12)  
at doListen (net.js:1500:7)  
at processTicksAndRejections (internal/process/task\_queues.js:85:21)

---

<div class="post-metadata">

**Author:** ![knolleary](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/knolleary/32/3_2.png) [@knolleary](https://discourse.nodered.org/u/knolleary)\
**Post date:** [11 May 2020 12:35 UTC](https://discourse.nodered.org/t/node-red-crashes-after-started-flows-uncaught-exception-eaddrnotavail-port-502/26478/2 "2020-05-11T12:35:26Z")

</div>

> [@kumarsemal](#):
>
> Error: listen EADDRNOTAVAIL: address not available 10.8.0.10:502

You have a node in your flow that is trying to access 10.8.0.10, port 502. But it isn't accessible for some reason. It could be a permissions issue, or it could just be wrong.

Whatever the node is, it should be handling this error and not letting go uncaught.

What nodes have you got in your flow?

As an aside, please make sure you give your posts a title that reflects the issue. Every post to the forum is someone asking for help, so a title of 'please suggest how to solve this problem' doesn't give any information.

---

<div class="post-metadata">

**Author:** ![Steve-Mcl](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/steve-mcl/32/4826_2.png) [@Steve-Mcl](https://discourse.nodered.org/u/Steve-Mcl)\
**Post date:** [11 May 2020 12:50 UTC](https://discourse.nodered.org/t/node-red-crashes-after-started-flows-uncaught-exception-eaddrnotavail-port-502/26478/3 "2020-05-11T12:50:46Z")

</div>

My guess is you have modbus TCP node installed? (port 502 is notmally modbus TCP)

You could start in safe mode and edit it or remove it.

If I am correct, can you tell us which one it is [from this list](https://flows.nodered.org/search?term=modbus&type=node)?

---

<div class="post-metadata">

**Author:** ![kuema](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/kuema/32/6542_2.png) [@kuema](https://discourse.nodered.org/u/kuema)\
**Post date:** [11 May 2020 13:14 UTC](https://discourse.nodered.org/t/node-red-crashes-after-started-flows-uncaught-exception-eaddrnotavail-port-502/26478/4 "2020-05-11T13:14:26Z")

</div>

"Address not available" suggests you try to bind to an interface with IP "10.8.0.10", but none has been found for that address on your system. This is a standard socket error.

Could you check your available network interfaces and assigned IP addresses?

---

<div class="post-metadata">

**Author:** ![Steve-Mcl](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/steve-mcl/32/4826_2.png) [@Steve-Mcl](https://discourse.nodered.org/u/Steve-Mcl)\
**Post date:** [11 May 2020 14:05 UTC](https://discourse.nodered.org/t/node-red-crashes-after-started-flows-uncaught-exception-eaddrnotavail-port-502/26478/5 "2020-05-11T14:05:55Z")

</div>

I agree with what you say but NO contrib node should crash node-red.

It seems "a node" is NOT handling (`Uncaught Exception`)

So I'd like the OP to identify the node so he / I can check its raised as an issue on the repo (for the good of the community)

PS, @kumarsemal I'm going to update that title - its not descriptive enough and is not going to attract the right attention.

---

<div class="post-metadata">

**Author:** ![kuema](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/kuema/32/6542_2.png) [@kuema](https://discourse.nodered.org/u/kuema)\
**Post date:** [11 May 2020 17:40 UTC](https://discourse.nodered.org/t/node-red-crashes-after-started-flows-uncaught-exception-eaddrnotavail-port-502/26478/6 "2020-05-11T17:40:13Z")

</div>

No, of course they shouldn't crash the runtime. 😅

Is the OP by any chance using the [node-red-contrib-modbus](https://flows.nodered.org/node/node-red-contrib-modbus) nodes?  
We tried them a while back at work in an R&D project and had similar troubles (mainly crashing, blocked ports, ...). The error handling and resource management was a bit _erratic_, at least back then. 🤔  
Unfortunately, we didn't have the resources to improve them (our team is rather small, now even more so).

---

<div class="post-metadata">

**Author:** ![Steve-Mcl](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/steve-mcl/32/4826_2.png) [@Steve-Mcl](https://discourse.nodered.org/u/Steve-Mcl)\
**Post date:** [11 May 2020 18:57 UTC](https://discourse.nodered.org/t/node-red-crashes-after-started-flows-uncaught-exception-eaddrnotavail-port-502/26478/7 "2020-05-11T18:57:44Z")

</div>

I'm sure when I played with modbus some time back it was the same thing as you describe.

There are a number of closed issues very similar.

Hopefully the op will respond.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)\
**Post date:** [10 July 2020 18:57 UTC](https://discourse.nodered.org/t/node-red-crashes-after-started-flows-uncaught-exception-eaddrnotavail-port-502/26478/8 "2020-07-10T18:57:49Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
