# Node-red execution error

**URL:** https://discourse.nodered.org/t/node-red-execution-error/62878
**Category:** General
**Created:** [20 May 2022 08:20 UTC](https://discourse.nodered.org/t/node-red-execution-error/62878 "2022-05-20T08:20:25Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![haeWoozu](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/haewoozu/32/61599_2.png) [@haeWoozu](https://discourse.nodered.org/u/haeWoozu)
#### Post date: [20 May 2022 08:20 UTC](https://discourse.nodered.org/t/node-red-execution-error/62878/1 "2022-05-20T08:20:25Z")

</div>

hello. I'm not good at English, so please understand.  
node-red terminated abnormally. And I get the following error and it doesn't work.

 ![image](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/3X/9/a/9a5435042273492827baa490a2b22529c730ca60.png)

> 20 May 17:13:21 - [info] Server now running at [http://127.0.0.1:1880/](http://127.0.0.1:1880/)  
> 20 May 17:13:21 - [info] Starting flows  
> 20 May 17:13:21 - [info] Started flows  
> 20 May 17:13:21 - [red] Uncaught Exception:  
> 20 May 17:13:21 - [error] Error: listen EADDRINUSE: address already in use 0.0.0.0:14502  
> at Server.setupListenHandle [as \_listen2] (node:net:1372:16)  
> at listenInCluster (node:net:1420:12)  
> at doListen (node:net:1559:7)  
> at processTicksAndRejections (node:internal/process/task\_queues:84:21)

I tried to search for 14502 port usage, but it turns out that it is not the port in use.  
I rebooted my computer and tried reinstalling node.js, but to no avail.

I am using it on windows. What should I do

😥😭😭😭

---

<div class="post-metadata">

### Author: ![Trying\_to\_learn](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/trying_to_learn/32/28400_2.png) [@Trying\_to\_learn](https://discourse.nodered.org/u/Trying_to_learn)
#### Post date: [20 May 2022 08:28 UTC](https://discourse.nodered.org/t/node-red-execution-error/62878/2 "2022-05-20T08:28:18Z")

</div>

To me the IP address of `0.0.0.0` is a flag there is something else going on.

---

<div class="post-metadata">

### Author: ![Steve-Mcl](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/steve-mcl/32/4826_2.png) [@Steve-Mcl](https://discourse.nodered.org/u/Steve-Mcl)
#### Post date: [20 May 2022 08:33 UTC](https://discourse.nodered.org/t/node-red-execution-error/62878/3 "2022-05-20T08:33:51Z")

</div>

> [@haeWoozu](#):
>
> I tried to search for 14502 port usage, but it turns out that it is not the port in use.

It might be reserved

`netsh int ip show excludedportrange protocol=tcp`

 ![image](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/3X/c/3/c30a4aeec9f36c5e4c241adf601ea1e84298e72d.png)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)
#### Post date: [3 June 2022 08:34 UTC](https://discourse.nodered.org/t/node-red-execution-error/62878/4 "2022-06-03T08:34:43Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
