# Node-red server with nginx reverse proxy howto guide

**URL:** https://discourse.nodered.org/t/node-red-server-with-nginx-reverse-proxy-howto-guide/27397
**Category:** FAQs
**Created:** [27 May 2020 23:28 UTC](https://discourse.nodered.org/t/node-red-server-with-nginx-reverse-proxy-howto-guide/27397 "2020-05-27T23:28:07Z")
**Posts on this page:** 1
**Showing post:** 6

<div class="post-metadata">

### Author: ![afelix](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/afelix/32/9743_2.png) [@afelix](https://discourse.nodered.org/u/afelix)
#### Post date: [28 May 2020 09:24 UTC](https://discourse.nodered.org/t/node-red-server-with-nginx-reverse-proxy-howto-guide/27397/6 "2020-05-28T09:24:21Z")

</div>

> [@meeki007](#):
>
> Lets block 404, 444, 403, 400 responses from the server. Feel free to read up on these codes but the gist of it is we will be blocking people trying to gain access to areas they should not be trying to get into.

In the context of using node-red, a 404 error is occasionally seen on actual usage too. Especially when editing flows and having a typo in a url somewhere it’s what will make you notice you’ve made a mistake. Is this handled somewhere, or will those connections be dropped too? Note that I’m on mobile and have only quickly scanned the fail2ban configuration. I certainly agree with blocking it, seeing a lot of interesting attempts on my CentOS cloud server with a similar fail2ban setup, but I wonder if it’s best in a node-red context that wouldn’t purely run flows in production.

---

_[View the full topic](https://discourse.nodered.org/t/node-red-server-with-nginx-reverse-proxy-howto-guide/27397)._
