# Node-Red won't start now

**URL:** <https://discourse.nodered.org/t/node-red-wont-start-now/85991>\
**Category:** General\
**Created:** [28 February 2024 10:25 UTC](https://discourse.nodered.org/t/node-red-wont-start-now/85991 "2024-02-28T10:25:45Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Trying\_to\_learn](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/trying_to_learn/32/28400_2.png) [@Trying\_to\_learn](https://discourse.nodered.org/u/Trying_to_learn)\
**Post date:** [28 February 2024 10:25 UTC](https://discourse.nodered.org/t/node-red-wont-start-now/85991/1 "2024-02-28T10:25:46Z")

</div>

This is what I'm seeing.

```auto
pi@TimePi:~/.node-red $ node-red --safe
28 Feb 21:24:00 - [info] 

Welcome to Node-RED
===================

28 Feb 21:24:00 - [info] Node-RED version: v3.0.2
28 Feb 21:24:00 - [info] Node.js version: v14.19.0
28 Feb 21:24:00 - [info] Linux 5.10.63-v7+ arm LE
28 Feb 21:24:01 - [info] Loading palette nodes
28 Feb 21:24:08 - [info] Dashboard version 3.6.0 started at /ui
28 Feb 21:24:10 - [warn] ------------------------------------------------------
28 Feb 21:24:10 - [warn] [node-red-node-rbe/rbe] 'rbe' already registered by module node-red
28 Feb 21:24:10 - [warn] ------------------------------------------------------
28 Feb 21:24:10 - [info] Settings file : /home/pi/.node-red/settings.js
28 Feb 21:24:10 - [info] HTTP Static : /home/pi/.node-red/public > /
28 Feb 21:24:10 - [info] Context store : 'default' [module=memory]
28 Feb 21:24:10 - [info] User directory : /home/pi/.node-red
28 Feb 21:24:10 - [warn] Projects disabled : set editorTheme.projects.enabled=true to enable
28 Feb 21:24:10 - [warn] Flows file name not set. Generating name using hostname.
28 Feb 21:24:10 - [info] Flows file : /home/pi/.node-red/flows_TimePi.json
(node:6771) NOTE: We are formalizing our plans to enter AWS SDK for JavaScript (v2) into maintenance mode in 2023.

Please migrate your code to use AWS SDK for JavaScript (v3).
For more information, check the migration guide at https://a.co/7PzMCcy
(Use `node --trace-warnings ...` to show where the warning was created)
28 Feb 21:24:10 - [error] Uncaught Exception:
28 Feb 21:24:10 - [error] Error: listen EADDRINUSE: address already in use 0.0.0.0:1880
    at Server.setupListenHandle [as _listen2] (net.js:1331:16)
    at listenInCluster (net.js:1379:12)
    at doListen (net.js:1516:7)
    at processTicksAndRejections (internal/process/task_queues.js:83:21)
pi@TimePi:~/.node-red $ 

```

This bit has me confused:

```auto
28 Feb 21:24:10 - [error] Error: listen EADDRINUSE: address already in use 0.0.0.0:1880
    at Server.setupListenHandle [as _listen2] (net.js:1331:16)
    at listenInCluster (net.js:1379:12)
    at doListen (net.js:1516:7)
    at processTicksAndRejections (internal/process/task_queues.js:83:21)

```

Sorry, someone?

---

<div class="post-metadata">

**Author:** ![Bobo](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/bobo/32/8401_2.png) [@Bobo](https://discourse.nodered.org/u/Bobo)\
**Post date:** [28 February 2024 10:41 UTC](https://discourse.nodered.org/t/node-red-wont-start-now/85991/2 "2024-02-28T10:41:14Z")

</div>

> [@Trying\_to\_learn](#):
>
> `address already in use 0.0.0.0`

NR already running perhaps? Have you checked?

---

<div class="post-metadata">

**Author:** ![Trying\_to\_learn](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/trying_to_learn/32/28400_2.png) [@Trying\_to\_learn](https://discourse.nodered.org/u/Trying_to_learn)\
**Post date:** [28 February 2024 10:44 UTC](https://discourse.nodered.org/t/node-red-wont-start-now/85991/3 "2024-02-28T10:44:05Z")

</div>

Thanks.

AFAIK, it isn't.

Alas - ITMT - I reloaded an older backup and it now seems to be working.

When I tried to view either the `dashboard` or `edit screen` I got a _No connection_ message.

So I `ssh` to the machine and it kind of implied it had exited/failed/stopped.

Sorry.  
As I have kind of fixed it, I'll close this thread.

# Note:

I do **NOT** know what happened.  
Only that _rolling back_ to an older version of the flows seems to have resolved the problem.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)\
**Post date:** [13 March 2024 10:44 UTC](https://discourse.nodered.org/t/node-red-wont-start-now/85991/4 "2024-03-13T10:44:39Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
