# NodeRed 3.0 Docker - Error writing context: Error: EACCES: permission denied

**URL:** <https://discourse.nodered.org/t/nodered-3-0-docker-error-writing-context-error-eacces-permission-denied/65210>\
**Category:** General\
**Tags:** docker\
**Created:** [17 July 2022 11:47 UTC](https://discourse.nodered.org/t/nodered-3-0-docker-error-writing-context-error-eacces-permission-denied/65210 "2022-07-17T11:47:11Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![PuckeyP](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/puckeyp/32/63446_2.png) [@PuckeyP](https://discourse.nodered.org/u/PuckeyP)\
**Post date:** [17 July 2022 11:47 UTC](https://discourse.nodered.org/t/nodered-3-0-docker-error-writing-context-error-eacces-permission-denied/65210/1 "2022-07-17T11:47:11Z")

</div>

Hi All,  
I upgrade to Node Red 3.0.  
Had some problems withe the rfx-com module, but was able to fix that with a reinstall of the module,  
Now every 30 seconds I have an error in my logs:

```auto
17 Jul 13:37:59 - [error] Error writing context: Error: EACCES: permission denied, open '/data/Persistent Context/global/global.json.1658057879990.tmp'

```

Permissions seem to be OK.

Docker run file I use:

```auto
sudo docker run --restart always -d \
                --name NodeRed \
                -p 1880:1880 \
                -v /docker/NodeRed:/data \
                -e TZ=Europe/Amsterdam \
                --device=/dev/ttyUSB0:/dev/ttyUSB0 \
                nodered/node-red

```

Any suggestions how to solve this?  
PPee

---

<div class="post-metadata">

**Author:** ![hardillb](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/hardillb/32/12373_2.png) [@hardillb](https://discourse.nodered.org/u/hardillb)\
**Post date:** [17 July 2022 12:59 UTC](https://discourse.nodered.org/t/nodered-3-0-docker-error-writing-context-error-eacces-permission-denied/65210/2 "2022-07-17T12:59:49Z")

</div>

Double check the premissions on the `/docker/NodeRED` directory, everything, including the directory it's self, should be owned by uid 1000 gid 1000

---

<div class="post-metadata">

**Author:** ![PuckeyP](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/puckeyp/32/63446_2.png) [@PuckeyP](https://discourse.nodered.org/u/PuckeyP)\
**Post date:** [19 July 2022 07:08 UTC](https://discourse.nodered.org/t/nodered-3-0-docker-error-writing-context-error-eacces-permission-denied/65210/3 "2022-07-19T07:08:52Z")

</div>

Thx hardillb  
chown -R 1000:1000 solved it

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)\
**Post date:** [2 August 2022 07:09 UTC](https://discourse.nodered.org/t/nodered-3-0-docker-error-writing-context-error-eacces-permission-denied/65210/4 "2022-08-02T07:09:37Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
