Rpi-gpio : Raspberry Pi specific node set inactive

Thanks for the information

The OS was updated last week and you are probably the 1st person to try it out

What do you see if you run these commands?
apt-cache policy rpi.gpio
groups

pi@raspberrypi:~ $ apt-cache policy rpi.gpio
python3-rpi.gpio:
  Installato: (nessuno)
  Candidato:  0.7.0-0.2+b1
  Tabella versione:
     0.7.0-0.2+b1 500
        500 http://raspbian.raspberrypi.org/raspbian bullseye/main armhf Packages
python-rpi.gpio:
  Installato: (nessuno)
  Candidato:  (nessuno)
  Tabella versione:
rpi.gpio-common:
  Installato: 0.7.0-0.2+b1
  Candidato:  0.7.0-0.2+b1
  Tabella versione:
 *** 0.7.0-0.2+b1 500
        500 http://raspbian.raspberrypi.org/raspbian bullseye/main armhf Packages
        100 /var/lib/dpkg/status
pi@raspberrypi:~ $ groups
pi adm dialout cdrom sudo audio video plugdev games users input netdev lpadmin gpio i2c spi
pi@raspberrypi:~ $

I am currently re-imaging a PiZero2 card to see if the issue replicates on one of them

Thanks a lot!!

Alan

This thread has another user unable to access the GPIO with raspbian bullseye (which has only just been released).

1 Like

I saw it now

1 Like

Please stay on this thread :slight_smile:

Ok, excuse me!

I have googled extensively and can't find any reference to any differences in bullseye relating to GPIO.

No problem :slight_smile:
The card I have put into my Pi is not letting me connect to it :frowning:
I'm am re-imaging it again

Sorry for delay :frowning:

image

Thank you for informing!

Now I think: when I imaged for the first time on Monday, I've found the same problem, RPI was killed and also video had non signal. I've re-immaged and all start as we attend!!

I can't access the Pi :frowning:
image
I'll keep on trying to sort out my issue but I don't think I will get it done quickly :frowning:

I use cmd by Windows for ssh connectionssh pi@raspberrypi.local. You should have win 10 2018 update to do this

Thank you -that works - must be a problem with putty and new OS

Do you know whether the gpio node uses python to interface with rpi.gpio? I notice that on my Buster system that python-rpi.gpio is installed, but it isn't here, in fact there is no python-rpi.gpio package. There is python3-rpi.gpio though.

@alanmasu, as an experiment could you install that and then restart node-red. I am not very hopeful but worth trying.
sudo apt install python3-rpi.gpio
then restart node-red. In fact maybe a good idea to reboot. Then check the startup log for node-red.
If that doesn't do it then could you enable trace level debugging in settings.js. If you edit that file (in your .node-red folder) and find the logging section. In there you should see
level: "info"
change it to
`level: "trace"
Then stop node-red and start it again. There should be a lot of extra stuff in the log. See if it says anything extra about gpio.

[Edit] Before doing any of the above could you check your system is up to date, there may have been some updates since the image was made
sudo apt update
sudo apt full-upgrade
Reboot and check node-red again.

1 Like

last time I dove into what the node does is it ran a prog called nrgpio.py and that reference RPi.GPIO module (IIRC)

1 Like

I will try the install 1st without doing any updates just to make sure it fails :slight_smile:

Just watching the paint dry at the moment

image

The suggestion to update was meant for @alanmasu in fact.

It might be the missing package then.