# \[SOLVED\] "Failed to connect to http://localhost:1880" when running any "node-red admin" command for proxmox container

**URL:** <https://discourse.nodered.org/t/solved-failed-to-connect-to-http-localhost-1880-when-running-any-node-red-admin-command-for-proxmox-container/93899>\
**Category:** General\
**Created:** [14 December 2024 08:54 UTC](https://discourse.nodered.org/t/solved-failed-to-connect-to-http-localhost-1880-when-running-any-node-red-admin-command-for-proxmox-container/93899 "2024-12-14T08:54:23Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![woody4165](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/woody4165/32/97194_2.png) [@woody4165](https://discourse.nodered.org/u/woody4165)\
**Post date:** [14 December 2024 08:54 UTC](https://discourse.nodered.org/t/solved-failed-to-connect-to-http-localhost-1880-when-running-any-node-red-admin-command-for-proxmox-container/93899/1 "2024-12-14T08:54:23Z")

</div>

Hi all

I'm trying to run "node-red admin login" in a Node-Red 4.0.5 installed in a privileged Proxmox container, but I always receive a "Failed to connect to [http://localhost:1880](http://localhost:1880)" error

Strangely, if I run "curl [http://localhost:1880](http://localhost:1880)" from same console, I get the NR page

What can I check?

Thanks

---

<div class="post-metadata">

**Author:** ![meeki007](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/meeki007/32/12499_2.png) [@meeki007](https://discourse.nodered.org/u/meeki007)\
**Post date:** [14 December 2024 15:05 UTC](https://discourse.nodered.org/t/solved-failed-to-connect-to-http-localhost-1880-when-running-any-node-red-admin-command-for-proxmox-container/93899/2 "2024-12-14T15:05:31Z")

</div>

> [@woody4165](#):
>
> Proxmox container

Are you running the command "node-red admin login" from inside the Proxmox container?

In the console your running the curl command first look up the vmid of the container

```auto
$ pct list

```

Then using the vmid of the nodered container shell into it

```auto
$ pct enter vmid

```

now type commands you want to. edit files like settings.js ....etc  
when your done and want back out type:

```auto
exit

```

hope this helps ya.

---

<div class="post-metadata">

**Author:** ![woody4165](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/woody4165/32/97194_2.png) [@woody4165](https://discourse.nodered.org/u/woody4165)\
**Post date:** [14 December 2024 15:43 UTC](https://discourse.nodered.org/t/solved-failed-to-connect-to-http-localhost-1880-when-running-any-node-red-admin-command-for-proxmox-container/93899/3 "2024-12-14T15:43:32Z")

</div>

Absolutely!  
I'm running the command from the LXC container console

---

<div class="post-metadata">

**Author:** ![meeki007](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/meeki007/32/12499_2.png) [@meeki007](https://discourse.nodered.org/u/meeki007)\
**Post date:** [14 December 2024 15:59 UTC](https://discourse.nodered.org/t/solved-failed-to-connect-to-http-localhost-1880-when-running-any-node-red-admin-command-for-proxmox-container/93899/4 "2024-12-14T15:59:25Z")

</div>

> [@woody4165](#):
>
> node-red admin login

I see the command is

```auto
node-red-admin login 

```

if you install it separate

see ---\> [Command-line Administration : Node-RED](https://nodered.org/docs/user-guide/node-red-admin)

> To use the version included with `node-red` , use the command `node-red admin`

---

<div class="post-metadata">

**Author:** ![woody4165](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/woody4165/32/97194_2.png) [@woody4165](https://discourse.nodered.org/u/woody4165)\
**Post date:** [14 December 2024 16:13 UTC](https://discourse.nodered.org/t/solved-failed-to-connect-to-http-localhost-1880-when-running-any-node-red-admin-command-for-proxmox-container/93899/5 "2024-12-14T16:13:08Z")

</div>

I have not installed separately.

I've solved using the "target" option

So

`node-red admin target http://myIP:1880`

and then

`node-red admin login`

and it worked

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)\
**Post date:** [28 December 2024 16:13 UTC](https://discourse.nodered.org/t/solved-failed-to-connect-to-http-localhost-1880-when-running-any-node-red-admin-command-for-proxmox-container/93899/6 "2024-12-28T16:13:29Z")

</div>

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.
