Start up error - Uncaught Exception

On Windows 10 Pro I installed latest version yesterday and managed to get my first flow working, later in the day the PC quietly crashed with NR still running. Today when I try to start NR I get the following messages:

13 Mar 17:08:14 - [info] Node-RED version: v1.2.9
13 Mar 17:08:14 - [info] Node.js  version: v15.11.0
13 Mar 17:08:14 - [info] Windows_NT 10.0.19042 x64 LE
13 Mar 17:08:15 - [info] Loading palette nodes
13 Mar 17:08:16 - [warn] ------------------------------------------------------
13 Mar 17:08:16 - [warn] [node-red-contrib-lorawan-packet-decrypt-nwkey-appkey/lorawan-packet-decrypt-nwkey-appkey] Error: Cannot find module './lora-packet'
Require stack:
- C:\Users\chris\.node-red\node_modules\node-red-contrib-lorawan-packet-decrypt-nwkey-appkey\lorawan-packet-decrypt-nwkey-appkey\lorawan-packet-decrypt-nwkey-appkey.js
- C:\Users\chris\AppData\Roaming\npm\node_modules\node-red\node_modules\@node-red\registry\lib\loader.js
- C:\Users\chris\AppData\Roaming\npm\node_modules\node-red\node_modules\@node-red\registry\lib\index.js
- C:\Users\chris\AppData\Roaming\npm\node_modules\node-red\node_modules\@node-red\runtime\lib\nodes\index.js
- C:\Users\chris\AppData\Roaming\npm\node_modules\node-red\node_modules\@node-red\runtime\lib\index.js
- C:\Users\chris\AppData\Roaming\npm\node_modules\node-red\lib\red.js
- C:\Users\chris\AppData\Roaming\npm\node_modules\node-red\red.js
13 Mar 17:08:16 - [warn] ------------------------------------------------------
13 Mar 17:08:16 - [info] Settings file  : C:\Users\chris\.node-red\settings.js
13 Mar 17:08:16 - [info] Context store  : 'default' [module=memory]
13 Mar 17:08:16 - [info] User directory : \Users\chris\.node-red
13 Mar 17:08:16 - [warn] Projects disabled : editorTheme.projects.enabled=false
13 Mar 17:08:16 - [info] Flows file     : \Users\chris\.node-red\flows_MotleySim.json
13 Mar 17:08:16 - [error] Uncaught Exception:
13 Mar 17:08:16 - [error] Error: listen EACCES: permission denied
    at Server.setupListenHandle [as _listen2] (node:net:1293:21)
    at listenInCluster (node:net:1358:12)
    at doListen (node:net:1496:7)
    at processTicksAndRejections (node:internal/process/task_queues:82:21)

Any help gratefully received - I would really like to make NR work.


This suggests node-red is already running. Have you tried accessing it in the browser?

Or something else is using port 1880


Thanks for the reply,

After the pc crashed yesterday it was rebooted and I haven't yet set NR to run automatically so I don't think it's running and http://localhost:1880 doesn't connect.

Then first try starting it in safe mode to prevent that other error and see what happens. But do also check to see if anything has grabbed port 1880.


Thanks for the reply, I tried node-red --safe and I get the same result, I'm nor sure how to check if anything else is using port 1880, but since it worked yesterday before the crash I suspect there is nothing else on that port.

Does this pc have hyper v installed? It's know to block allocate ports.

Also what does netstat -anb report?

Follow this instructions in this post to find a process using port 1880.

Lastly, you could try starting node-red with a different port e.g. node-red -p 18880

Follow info

From PowerShell Get-Process -Id (Get-NetTCPConnection -LocalPort 1880).OwningProcess

Or from PowerShell or cmd (as admin): netstat -a -b


Thanks again for the reply, the netstat -anb (in admin powershell) gives a long list but I see no mention of I do have Vmware Workstation on this PC - for Linux VM testing.

As you suggested I then tried node-red -p 18880 and success ! (a few warnings only).

Out of curiosity I than ran node-red without the -p switch and success again, curious so what ever was on port 1880 yesterday is not there today (I shut this pc down at night).

Either way with thanks to Steve-McI I am back running :slight_smile:

Thanks for the reply, I did try your suggestion and it gives a very informative list and is something I have stored away for future use.

I did have some success - see my other reply :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.