# Synology NAS: MySQL Error: connect ECONNREFUSED 127.0.0.1:3306 - Problem solved

**URL:** <https://discourse.nodered.org/t/synology-nas-mysql-error-connect-econnrefused-127-0-0-1-3306-problem-solved/74814>\
**Category:** General\
**Tags:** database\
**Created:** [6 February 2023 22:05 UTC](https://discourse.nodered.org/t/synology-nas-mysql-error-connect-econnrefused-127-0-0-1-3306-problem-solved/74814 "2023-02-06T22:05:59Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![freenr](https://avatars.discourse-cdn.com/v4/letter/f/838e76/32.png) [@freenr](https://discourse.nodered.org/u/freenr)\
**Post date:** [6 February 2023 22:05 UTC](https://discourse.nodered.org/t/synology-nas-mysql-error-connect-econnrefused-127-0-0-1-3306-problem-solved/74814/1 "2023-02-06T22:05:59Z")

</div>

Hi,  
I have a Synology DS218.  
Node-red and MariaDB10 installed.  
It was not possible to connect to database.  
The solution for me was to open MariaDB from the Synology PacketCenter and enable TCP/IP.  
Hope this helps someone.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)\
**Post date:** [7 April 2023 22:06 UTC](https://discourse.nodered.org/t/synology-nas-mysql-error-connect-econnrefused-127-0-0-1-3306-problem-solved/74814/2 "2023-04-07T22:06:25Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
