Tasmota node not working after Tasmota 8.30 firmware update?

It might be worth submitting an issue on the node's github page, it appears to be actively maintained.

Just done that.
I have also enabled / disabled SSL, no difference.
If I deinstall the enocean node and restart Node-RED, both other nodes continue to work again.

Can I change the subject, since the new Tasmota firmware does not seem to have any impact on the error!?

You opened the thread so you can change the topic/subject. Click the pencil icon next to it.

Probably nothing to do with your problem or issue - but there has been an emergency update for Tasmota.
It is now 8.3.1

why don't you use MQTT?
i think you are german (i'm too) and if you need some help with MQTT send me a message.

I have updated all my tasmota switches to 8.3.1 now, but no difference.
Since the error occurs, just after installing the enocean node (without using the enocean or tasmota node), there seems no correlation.

I will have to go deeper in MQTT and learn how to read the state of a smart plug over a MQTT command. I have already contacted @Maximus1, because in german it's much easier for me.

Hi Stefan,
I hope you get the problem sorted.
My mains switches are SonOff S20 devices flashed with Tasmota.
They work fine with Tasmota and "talk" nicely to/from Node-RED via MQTT.
Let me know if you want me to post some of my Node-RED flows.
Regards, David.

This is my flow with the Tasmota node:


[{"id":"b1cb0a2f.b249d8","type":"ui_switch","z":"72f946c2.13e94","name":"","label":"HeizlĆ¼fter Bad","tooltip":"","group":"1b8bd334.e6a735","order":7,"width":0,"height":0,"passthru":false,"decouple":"true","topic":"switch1","style":"","onvalue":"true","onvalueType":"bool","onicon":"","oncolor":"","offvalue":"false","offvalueType":"bool","officon":"","offcolor":"","x":480,"y":200,"wires":[["2c0fb83f.f4b8e"]]},{"id":"2c0fb83f.f4b8e","type":"Tasmota Switch","z":"72f946c2.13e94","broker":"7f211795.773398","device":"tasmotaS5","name":"Steckdose Bad","outputs":2,"uidisabler":true,"fullTopic":"","cmndPrefix":"","statPrefix":"","telePrefix":"","x":200,"y":200,"wires":[["b1cb0a2f.b249d8"],[]]},{"id":"1b8bd334.e6a735","type":"ui_group","z":"","name":"OG","tab":"f7cc43c0.99d968","order":2,"disp":true,"width":"6","collapse":true},{"id":"7f211795.773398","type":"mqtt-broker","z":"","name":"Mosquitto","broker":"localhost","port":"1883","clientid":"","usetls":false,"compatmode":false,"keepalive":"60","cleansession":true,"birthTopic":"","birthQos":"0","birthPayload":"","closeTopic":"","closeQos":"0","closePayload":"","willTopic":"","willQos":"0","willPayload":""},{"id":"f7cc43c0.99d968","type":"ui_tab","z":"","name":"BSB","icon":"dashboard","order":1,"disabled":false,"hidden":false}]

Very simple!

After deploying, it reads the actual state of the switch, I can use the physical button on the plug, I can use the button in the ui from any web browser. How do I read the current state of the plug switch with MQTT and set the button according to this state?

Due to a hint from @Maximus1 I managed to use MQTT without the tasmota node:

My former problem was, that I didn't feed the plug with a empty message, so that MQTT returns the current state back to the stat/... node:

Because of the group command tasmotas, I do not need to send it to all plugs separately.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.