# TCP Request Node Error not caught

**URL:** <https://discourse.nodered.org/t/tcp-request-node-error-not-caught/59021>\
**Category:** General\
**Created:** [26 February 2022 12:53 UTC](https://discourse.nodered.org/t/tcp-request-node-error-not-caught/59021 "2022-02-26T12:53:28Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![mlschuh](https://avatars.discourse-cdn.com/v4/letter/m/ce73a5/32.png) [@mlschuh](https://discourse.nodered.org/u/mlschuh)\
**Post date:** [26 February 2022 12:53 UTC](https://discourse.nodered.org/t/tcp-request-node-error-not-caught/59021/1 "2022-02-26T12:53:29Z")

</div>

Hello!

I'm going to preface this with the fact that I'm running a rather old version, 1.0.3, for mostly political reasons. It's a production system that's been in place for many years and budget to update it, no matter how safe it should be, doesn't really exist unless forced. With that said, this post is more of a "Has anyone seen this before and do we know if it specifically has been resolved since".

I have a flow that contains many TCP Request nodes. Last night, one of them threw a ECONNRESET, restarted the NR process in safe mode, and sat there. It was easy enough to re-deploy but this is the second time and I thought that NR should be catching all of these errors instead of it crashing the process.There's probably a dozen reasons why the connection could have been reset so I don't think a root-cause analysis would be fruitful. I also have no way of reliably reproducing it.

 ![Screen Shot 2022-02-26 at 7.38.45 AM](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/3X/b/6/b6f4a3d0fb3447e7d6375fd951e86145bb82d5a2.png)

This specific node with this name appears in a few different places so I can't be sure of the exact one that failed but here's a (probably less than useful) view of one inside a subflow.

 ![Screen Shot 2022-02-26 at 7.39.37 AM](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/3X/1/e/1e6a7af20d89ad9f35b46d60d757dc474e780f5a.png)

**Environment**  
Docker on Ubuntu

**Version**  
1.0.3

Has anyone seen this before? Or better yet, was this a known bug and resolved in the prior few years?

---

<div class="post-metadata">

**Author:** ![Colin](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/colin/32/17040_2.png) [@Colin](https://discourse.nodered.org/u/Colin)\
**Post date:** [26 February 2022 15:39 UTC](https://discourse.nodered.org/t/tcp-request-node-error-not-caught/59021/2 "2022-02-26T15:39:57Z")

</div>

That does suggest a bug in the TCP node. Nodes should catch any errors and deal with them. If the node does not catch it then it is passed up to node-red which has no option other than to terminate. Anything else might be unsafe.

Most likely the bug was fixed a long time ago. If it does still exist then if reported now it would be fixed urgently, I am sure. You could trawl back through the node-red release notes to see if you can find it.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex026/uploads/nodered/original/1X/d073cd938eafa2e558d7c2cd59003b3ef4963033.png) [@system](https://discourse.nodered.org/u/system)\
**Post date:** [27 April 2022 15:39 UTC](https://discourse.nodered.org/t/tcp-request-node-error-not-caught/59021/3 "2022-04-27T15:39:57Z")

</div>

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.
