# Unable to start Node-RED docker container

**URL:** https://discourse.nodered.org/t/unable-to-start-node-red-docker-container/9632
**Category:** General
**Created:** [31 March 2019 10:45 UTC](https://discourse.nodered.org/t/unable-to-start-node-red-docker-container/9632 "2019-03-31T10:45:09Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![AlexKalopsia](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/alexkalopsia/32/7195_2.png) [@AlexKalopsia](https://discourse.nodered.org/u/AlexKalopsia)
#### Post date: [31 March 2019 10:45 UTC](https://discourse.nodered.org/t/unable-to-start-node-red-docker-container/9632/1 "2019-03-31T10:45:09Z")

</div>

Hi everyone, I have Docker running on my NAS. What I am trying to do is creating a Node-RED docker to communicate with my HomeAssistant (running in another container).

I get what seem to be permission errors after starting the container.

`Error: EACCES: permission denied, copyfile '/usr/src/node-red/node_modules/node-red/settings.js' -> '/data/settings.js'`

I am using my PUID and PGID that I use for any other container, but only Node-RED is giving me problems.

```auto
docker run -d \
--name=node-red \
--restart=always \
-p 1880:1880 \
-u 1027:100 \
-v /volume1/docker/node-red/data \
nodered/node-red-docker:v10

```

Do you have any advise on how to fix this?

Thanks

---

<div class="post-metadata">

### Author: ![dp3049](https://sea2.discourse-cdn.com/flex026/user_avatar/discourse.nodered.org/dp3049/32/84723_2.png) [@dp3049](https://discourse.nodered.org/u/dp3049)
#### Post date: [10 November 2023 22:16 UTC](https://discourse.nodered.org/t/unable-to-start-node-red-docker-container/9632/2 "2023-11-10T22:16:08Z")

</div>

HI @AlexKalopsia , did you get this solved? I just encountered the same issue. thanks.

---

<div class="post-metadata">

### Author: ![AndrewBeasley](https://avatars.discourse-cdn.com/v4/letter/a/f17d59/32.png) [@AndrewBeasley](https://discourse.nodered.org/u/AndrewBeasley)
#### Post date: [11 November 2023 00:23 UTC](https://discourse.nodered.org/t/unable-to-start-node-red-docker-container/9632/3 "2023-11-11T00:23:43Z")

</div>

The volume mapping looks wrong.  
Normally you would say _the actual directory colon container directory_ like

`/srv/docker/node-red/data:/data`

More details can be found at [https://docs.docker.com/storage/](https://docs.docker.com/storage/)
