AWS Marketplace

I have followed the instructions to install Flowfuse on AWS using the Market place. When the instance is running and I connect the start up script does not appear to setup the domain name. Any suggestions appreciated

Hey mtoko,

Are you running into issues in step 2 and not showing this image?



Please supply the full output from the setup script and the content of /opt/flowforge/etc/flowforge.yml

There is no option to enter the domain name


The script is only run once on your first login and is removed when the script ends as it does not makes sense to run it again.

Can I suggest you delete this VM and create a new one. Please capture the steps as login so we can see any errors the script presents.

Also please post text, not screen shots, they are much easier to read.

Also you should be logging in as the ubuntu user, not root

I am using the FlowFuse subscription on Amazon Marketplace and there is no option for a Ubuntu image only a Amazon Machine image, so the user is root

The FlowFuse AMI image is an modified Ubuntu image, when you connect to the image you should be connecting as the ubuntu user, not root

e.g. when you click on the connect button in the AWS console you will be presented with the following screen, edit the username to be ubuntu not root


Thanks for the help. The ubuntu user worked and I went through the startup script with the domain name but there were a lot of errors. and the setup page was unavailable. I will check the domain name again and try again. Thank you

1 Like


I have set up another instance and used the ubuntu log in. The start up script appeared to work and I entered the domain as indicated. There was a long list of errors and the setup page was not available.

The errors are in this log

Any advice appreciated


Thanks for the help, I have resolved the issue

For others

1.) When connecting to the EC2 instance use ubuntu as user not root
2.) When I entered the domain name I used (*, it should have been just ( This was clear in the instructions but I missed it.