Bad colours on/in browser

Quick back story:
I use FireFox. Run Ubuntu 20.04

A long time ago when entering my password a colour requester popped up (unexpectedly) and I have had this little problem since - I think.

Sometimes when reading things the colour contrast is wrong and I can hardly read what is written.

People in/on the Firefox forum have helped me with SOME of the problems.
Though I can't say I am 100% sure, but the result does look better from what I remember it being.

But the underlying problem remains.

Without wanting to start a finger pointing game, here's what I know.
In FireFox some things are near impossible to read.

I was wanting to use the cronplus node and was looking at the instructions.

As you can see the big white rectangle on the right is near impossible to read.

I tried using "PRIVATE" mode... No change.

Today I even tried Opera....

Same. So it can't be a FireFox problem.

Does anyone else see this?
(Probably not)

But I am lost in what to do so I can read these kind of pages.

Have you checked what css class that element has? I suspect that it hasn't been styled though you are obviously using a dark mode theme.

What theme are you using & what version of cron plus?

@TotallyInformation No. Sorry, I don't even understand the question.

@Steve-Mcl 1.5.4

It isn't I am saying it is unique to that node.

It is just I was reading the instructions today and saw it happening on that node.

I can check other nodes too if needed. But that may be a slow process.

No, i know, however i recently fixed some rubbish CSS overrides in cron-plus. You can try V1.5.6 in the flow lib

You are using a dark mode theme are you not? There are likely some elements of Node-RED where the theme hasn't applied a style or possible where Node-RED still has manual styling so that the theme can't style it. The other possible issue - as Steve says - is that perhaps some nodes have applied manual styling themselves and so the theme is ignored there.

You or someone else would need to look at the mis-styled elements using the browser dev tools to find out which of these issues applies.


I could see there was an update.
Went to the palette manager and upated.

"You need to restart node-red....."


Load the manager... Still saying 1.5.5


1.5.6 was posted about 10 mins ago

Refresh your browser

Sorry.... Ok.

Dev tools.... eeeeech.... That is a whole different world to me.

I have very little understanding on how to use that stuff.

I guess - offering - would it be an idea to disable the dark theme and try again - sorry I didn't think of this before.

When I looked at the palette manager the first time it said 1.5.6 was there.

I updated it and was told I had to restart NR.

Stopped it and started it - as per screen shot.

When I went back into NR, it was saying it was version 1.5.5.

I did a SHIFT REFRESH on the page. Same.
(shift refresh - AFAIK that wipes the cache.)

If you are using "midnight-red" you might need to update that.

Also, I seem to remember that shading issue you have was fixed in newer node-red

So you likely need to update to latest node-red

I've got NR 2.1.4 now.

I'll check if there are updates to the midnight-red theme.

When doing the installing of that theme (looking at page now)
the command to install is to be run from the .node-red directory - yeah?

From memory - yes.

After a bit of messing around, I simply disabled it to get a base line.

(Though I should try to remember which part isn't readable.)
(But if it isn't readable... how do I know which part?) :wink:

Just checked... OK, it was the dawn bit... But anyway.

Seems it is the theme which is not liking it.

I'll maybe ask if anything can be done at that end of things.

Just the dark theme is less stressful on my eyes.

When I use other programs with WHITE background, I nearly have to wear sunnies to look at the screen. :wink:

Nope. You have to do it via the menus.
In FF that is Settings > Privacy & Security > History section - Clear History > select Cache and Offline web site data - OK

Sorry, I'll rephrase that.

Simply pressing REFRECH .. refreshes the page.

If things have changed at the remote end they may not be shown.

Pressing SHIFT REFRESH forces the browser to reload the entire page.

Or am I still wrong?

Ah well, life is full of choices :slight_smile: Live or learn?

Got cronplus updated to 1.5.6. Still happening.

Don't worry. It seems it is only that node.
I did a quick check and couldn't find any other node with the problem.

Not the end of the world.

It does not force it to reload absolutely everything. To be certain you have to go through the menus. I thought like you once, then the dashboard was misbehaving after an upgrade. Dave (I think) said basically what I have just written and he was correct. Forcing a cache clear through the menus fixed it.