Can not install dashboard on Raspberry Pi 4, please help

pi@raspberrypi:~/.node-red $ npm i node-red/node-red-dashboard

npm WARN engine node-red-dashboard@3.1.8: wanted: {"node":">=12"} (current: {"node":"10.24.0","npm":"2.15.12"})
npm WARN peerDependencies The peer dependency bufferutil@^4.0.1 included from ws will no
npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency
npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly.
npm WARN peerDependencies The peer dependency utf-8-validate@^5.0.2 included from ws will no
npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency
npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly.
\

bufferutil@4.0.6 install /home/pi/.node-red/node_modules/node-red-dashboard/node_modules/socket.io/node_modules/engine.io/node_modules/bufferutil
node-gyp-build

make: Entering directory '/home/pi/.node-red/node_modules/node-red-dashboard/node_modules/socket.io/node_modules/engine.io/node_modules/bufferutil/build'
CC(target) Release/obj.target/bufferutil/src/bufferutil.o
SOLINK_MODULE(target) Release/obj.target/bufferutil.node
COPY Release/bufferutil.node
make: Leaving directory '/home/pi/.node-red/node_modules/node-red-dashboard/node_modules/socket.io/node_modules/engine.io/node_modules/bufferutil/build'

utf-8-validate@5.0.9 install /home/pi/.node-red/node_modules/node-red-dashboard/node_modules/socket.io/node_modules/engine.io/node_modules/utf-8-validate
node-gyp-build

make: Entering directory '/home/pi/.node-red/node_modules/node-red-dashboard/node_modules/socket.io/node_modules/engine.io/node_modules/utf-8-validate/build'
CC(target) Release/obj.target/validation/src/validation.o
SOLINK_MODULE(target) Release/obj.target/validation.node
COPY Release/validation.node
make: Leaving directory '/home/pi/.node-red/node_modules/node-red-dashboard/node_modules/socket.io/node_modules/engine.io/node_modules/utf-8-validate/build'
npm ERR! Linux 5.15.52-v7l+
npm ERR! argv "/usr/bin/node" "/usr/local/bin/npm" "i" "node-red/node-red-dashboard"
npm ERR! node v10.24.0
npm ERR! npm v2.15.12
npm ERR! path /home/pi/.node-red/node_modules/node-red-dashboard/node_modules/socket.io/node_modules/engine.io/node_modules/@types/node/package.json
npm ERR! code ENOTDIR
npm ERR! errno -20
npm ERR! syscall open

npm ERR! ENOTDIR: not a directory, open '/home/pi/.node-red/node_modules/node-red-dashboard/node_modules/socket.io/node_modules/engine.io/node_modules/@types/node/package.json'
npm ERR!
npm ERR! If you need help, you may report this error at:
npm ERR! https://github.com/npm/npm/issues

npm ERR! Please include the following file with any support request:
npm ERR! /home/pi/.node-red/npm-debug.log

the minimum version for the latest node-red dashboard is node v12.
you seem to have a very old nodejs v10

Since you are on a raspberry you can try running the bash script from this link
to update to the latest node-red version and also it will update your nodejs to a compatible version
then you can try installing the dashboard again.

ps. its good to make a backup of your flows beforehand

2 Likes

Thank UnborN.

Also, tou shouldjust use npm i node-red-dashboard see