Cannot POST - Post raw data to a flow

Hi all, I am a newbie starting to work with Node-RED walking trough the many examples found here.
I am using a Raspi 4B 8GB with SignalK vers. 1.44.0 and its Node-RED plugin ver. 2.1.6.
Node version is 14.20.0.

I have simply copied into Node-RED the example flow found in the cookbook example "Post raw data to a flow" and after deploying, I ran the suggested curl command from a terminal window directly on the Raspi where Node-RED is running.
I get a Cannot POST error in reply; I made several searches to try to address the issue but found nothing of help.
As said I am new to this and I sincerely don't know how to dig in the issue to understand where the culprit is.
I know that it is supposed to work flawlessly, but it doesn't.
May I ask some help, please?

N.B: by the way I also tried with a fresh install of the same configuration and I get the same error

I figured it out with the help of the SignalK team.
It doesn't work because the security settings of SignalK, apply to the Node-RED plug in as well.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.