Can't send command via exec

Hi,

Trying to turn the screensaver on/off via the exec-node, but doesn't work.

Running on debian 11,
Command I try to use: cinnamon-screensaver-command with flags -d and -a

result:
stdout: Can't connect to screensaver!
stderr: Unable to init server: Could not connect: Connection refused
Unable to init server: Kunde inte ansluta: Connection refused
return code: {"code":0}

If i run with flag -h, I get all help, and -v gives me the version without problem.

If I run it from the terminal on the computer, executes as it should without errors.

if I run it from terminal on another computer it executes, but with same stderr

If I run it from my android with JuiceSSH, executes without problem, no error. the same when executed from android tasker using autotools SSH

So somehow it seems like the problem lies with NR

I have tried several configurations, like:

command: cinnamon-screensaver-command -a
command: cinnamon-screensaver-command and append -a
append with msg.payload etc, etc...

Running out of ideas here, so please help.

my setup:

Old laptop running Debian 11 and Supervised Home assistant (unsupported). Using the screen as an info-center, not easily accesible and would like to be able to turn the screen off when not home/night etc, and then back on when needed.

So the idea is that when HA trigger away, night etc, I will send a MQTT-message to the NR installation on the laptop. Yes, two NR needed, one for the HA, and one for the non HA part since HA doesn't communicate directly to the host, at least not that I have found out...

Thanks

Welcome to the forum @strelniece

Try adding DISPLAY=:1 in front of the command.

sorry, didn't work. this is what I wrote in the command-box:

DISPLAY=:1 cinnamon-screensaver-command -a

At least I assume I just write it as I do in the terminal.

Try DISPLAY=:0. If that doesn't work then I don't know.

Sorry, same result :frowning:

Not really a solution, but rather an alternative, used:
xset -display :0.0 dpms force on/off
instead and solved my problem.