Could not connect to MQTT broker hosted on OVH

Hi, please I could not connect to my broker with node red even that i tried it with MQTT spy and it woks normally could pub and sub data but with node red i get not connected i could not do anything without reaching the broker ?? please help me

Welcome to the forum @moussa869

Is that running on the same machine as node red is?

Tell us how you configured mqtt spy.

What OS/hardware are you running node-red on?

How did you install node-red?

Click on one of the MQTT In nodes you are using to test it and Export that node (Ctrl-E) and paste it here. When pasting use the </> button in the forum entry window.

What is the status showing under the MQTT node?

What is OVH?

node red is running in my computer
i just put server URI client ID a user name and password and some topics i use to communicate with the broker hosted in OVH (cloud ) in MQTT spy but whene am in nod red dosnt work
am running node red in windows with laptop i mad some exemple privied in the documentation it works (CSV URI)

        "id": "bf2454555afc5dc2",
        "type": "mqtt out",
        "z": "d741bddf9f6c9c2f",
        "name": "",
        "topic": "",
        "qos": "",
        "retain": "",
        "respTopic": "",
        "contentType": "",
        "userProps": "",
        "correl": "",
        "expiry": "",
        "broker": "dac71d767023fc83",
        "x": 370,
        "y": 320,
        "wires": []
        "id": "dac71d767023fc83",
        "type": "mqtt-broker",
        "name": "",
        "broker": "",
        "port": "1883",
        "clientid": "HUTCHINSON",
        "autoConnect": true,
        "usetls": false,
        "protocolVersion": "4",
        "keepalive": "60",
        "cleansession": true,
        "birthTopic": "",
        "birthQos": "0",
        "birthPayload": "",
        "birthMsg": {},
        "closeTopic": "",
        "closeQos": "0",
        "closePayload": "",
        "closeMsg": {},
        "willTopic": "",
        "willQos": "0",
        "willPayload": "",
        "willMsg": {},
        "userProps": "",
        "sessionExpiry": ""

Admin edit, corrected the flow format. You did not use the </> button

Did you put the user and password in node-red?

Please try and answer all the questions asked

yes i put the user and password in node-red
i install it normaly with the cmd and all the commande lines after installing Node.js
the status under MQTT node is desconected

Can you show us a screenshot of that?

Please stop node-red then start it again in a command window and copy/paste the full output here. This is the </> button you should use when pasting code, logs etc

In fact the node connect and disconnected with strange way i dont understant it

Looks like you have reused "HUTCHINSON" as the client ID in another MQTT client.

Try changing this to HUTCHINSON2. Does it still disconnect/connect over and over?

Failing that, you might have a bad topic or option set. So if the above doesn't work, tell us what broker type& version this is connecting to and show us how you have setup the client (broker config) properties in node-red

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.