Dashboard 2 missing Curly bracket crashed Node-RED

Hi has anyone seen this on Dashboard 2.0 template node.
I missed the closing Curly bracket {{item.appKey} and that crashed NR and requires a stop/start?

I also tried on a simple example in the template node this does the same {{msg.payload}.
Though missing the opening Curly bracket {msg.payload} works.

I've just tested this and Node-RED does not crash for me.

Please provide a minimal demo reproduceable flow and the following versions:

  1. node-red
  2. dashboard
  3. node (node -v)

Hi Steve I've tried this on two different Nr instances and the same behaviour.
Hit deploy flow becomes unresponsive and dashboard just shows loading.
NR v3.1.9 & Dashboard 2 v1.7.1

// Missing closing bracket {{msg.payload}
<span style="margin-left:5px;" v-if="msg.topic !== '' " style="margin-top: 10px;">{{msg.payload}</span>

<div style="padding:0px; margin:0px">
  <v-btn @click="send({payload: value})" style="width:200px;">Create device config</v-btn>
  <v-icon style="margin-left:20px;" v-if="msg.topic !== '' " v-bind:color="msg.topic" icon="mdi-clipboard-check"></v-icon>
  <span   style="margin-left:5px;" v-if="msg.topic !== '' " style="margin-top: 10px;">{{msg.payload}</span>

  // export export default {} has be included or temaplate doesn't work
  export default {

    /* define any styles here - supports raw CSS */
    .my-class {
        color: blue;

Is it node red that crashes or the browser hanging?

I can confirm it locks up the browser. Node-red runtime is not affected. closing tabs or restarting browser is enough to recover.

Sadly it is all too easy to lockup the browser with silly errors in a template node, I seem to manage it regurlarly. Part of the problem is the lack of syntax checking in the template editor.

I reported an occurence the first time I saw this Dashboard 2 Beta development - #42 by Colin

@Steve-Mcl @Colin Both thanks for confirming this.