Error message (and super slow load times) on first Node-red instance

Hi everyone, thank you in advanced for any help. Noob here...

Just did a clean install of node red on a raspi 3 (and raspi 2) after experiencing extremely slow load times [which was new after having run node-red on both for about a week without significant load times].

I didn't make significant changes other than importing some nodes from one to the other. However after a clean install of node-red it still takes about 30-60 seconds for the admin editor page to load and then populate the various palettes.

Additionally, I've noticed this error in the console tab of the inspector...

This is all with a fresh flash of buster-lite followed by a clean install of node-red using the bash cli found on the node-red website guide for running on raspberry pi and accessing the GUI from a MacBook.

any help?

When I start node red from the CLI this is the log:

Welcome to Node-RED

2 Jun 23:34:12 - [info] Node-RED version: v1.0.6
2 Jun 23:34:12 - [info] Node.js version: v12.18.0
2 Jun 23:34:12 - [info] Linux 4.19.97-v7+ arm LE
2 Jun 23:34:14 - [info] Loading palette nodes
2 Jun 23:34:19 - [info] Settings file : /home/pi/.node-red/settings.js
2 Jun 23:34:19 - [info] Context store : 'default' [module=memory]
2 Jun 23:34:19 - [info] User directory : /home/pi/.node-red
2 Jun 23:34:19 - [warn] Projects disabled : editorTheme.projects.enabled=false
2 Jun 23:34:19 - [info] Flows file : /home/pi/.node-red/flows_raspberrypi.json
2 Jun 23:34:19 - [info] Creating new flow file
2 Jun 23:34:19 - [warn]

Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

2 Jun 23:34:19 - [info] Server now running at
2 Jun 23:34:19 - [info] Starting flows
2 Jun 23:34:19 - [info] Started flows

You say it's a clean install but then say...

From the logs it looks like it takes only 7sec to launch so a guess would be you have a loop causing slow down perhaps?

If you start up with safe mode....

node-red --safe

... Is it much more responsive and usable?

If so, delete everything and deploy.

Is it still useable?

Thanks for the quick response! /Clarification (and apology)/

I realize my original message had a confusing timeline,

edit: Before the clean install it was working fine for about 6-7 days. Then suddenly started lagging around day 7. The only difference between before and after was moving some nodes from one raspi to the other using export/import.

Once everything started becoming laggy, I did an SD flash and clean install and still had the issue even without adding nodes.

Using the --safe peram worked better. However the palettes still take about 25 seconds to load and I have these two errors in the JavaScript console.

what resource is that, and how can I replace it/help it find it?

1 - which Pi are you takling about - i.e. which one did you reflash the sd card on, the pi3 or pi2?
2 - how big is the SD card and how much free space is on it?
3 - what brand is the SD card and how long have you been using it?
4 - how big is your flow - i.e. how many tabs, how many nodes (approximately)
5 - can you provide your flow? read How to share code or flow json

Again, thanks for responding!

  1. node-red running on both Pi (3 and 2) share the issue (which leads me to believe it might be a router issue (I have a cheap one ATM while waiting for new one to arrive.))
  2. the SD card is 32 GB and I expanded the filesystem before installing NR.
  3. the SD card is PNY (I know its not the best) but it is Class 10 U1 "speeds up to 100MB/s" -manufacturer website
  4. part 1 I also thought that the number of nodes added was causing the slowdown as well, which is why I reset the whole thing and cleaned install. But then speed wasn't depreciating as nodes were added, as it was slow to even open the admin GUI in the first place then slow to load the palettes. (But once open, runs smooth enough, deploying can take upwards of 15 seconds? maybe that's just normal and I was lucky for the first week or so?)
    part 2 The flow I eventually placed on has three tabs and about 100 nodes (I don't know if that is a lot... I had been looking at others' dashboard examples with much more complex setups and I assumed :man_facepalming: I'd be safe.)
  5. I would add the flow, but every time I've done it with the backticks, it says I'm over the character limit. So I exported and attached it to this, if you're feeling adventurous... :man_shrugging:

flows.json (38.8 KB)

For what it's worth; I can live with the way things are, I mostly just want reassurance that I haven't broken it all and ruined the stability or functionality.

That is not the norm.

Question. Where do you run the browser when accessing the node-red editor? On the pi or on another (beefier) pc?

Issue found/awkward confession:

So, turns out, the issue wasn't with node-red at all. I had a hung up PlexServer on completely unrelated machine that was overloading the router and modem.

I reset the PlexServer, reset the router and reset the modem and now all is back to normal... If only I had given up sooner and tried to watch some Dr. Who on Plex. I could've saved us all the time (and myself some embarrassment) by finding the issue sooner.

Thanks @Steve-Mcl and @zenofmud for your help!!

Though I do still get a weird error in the console, but NR and dashboard load super smooth and quick like a well oiled machine.

[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (, line 0)

Screen Shot 2020-06-03 at 10.57.01 AM|690x30

.map files are files only needed for debug- they help translate minified javascript (and css) back into something readable in the browser debug tools... so aren't needed for running at all - so not a problem that they can't be found.

@dceejay Thanks for helping clarify that.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.