Fronius-solar 1.0.4


I have updated “fronius-solar” to version 1.0.4 and now I receive the following error message:

"TypeError: fronius.GetPowerFlowRealtimeData is not a function"

Before the update it worked without any problems. Does anybody have the same Problem?

I found the following on github:

Maybe that is related to my problem

Yes, several apparently. Error after upgrading to 1.0.4 · Issue #31 · mabunixda/node-red-contrib-fronius-solar · GitHub

1 Like

Jesus - i am an blind idiot. Thanks
I will try to downgrade

I have tried to change the line 83 like described here:


Now i think i have got a bigger problem - but i dont know why

i get the following msg when i try to start node red via - node-red-start

Error loading settings file: /home/pi/.node-red/settings.js nodered.service: Main process exited, code=exited, status=1/FAILURE nodered.service: Failed with result 'exit-code'. nodered.service: Service RestartSec=100ms expired, scheduling restart. nodered.service: Scheduled restart job, restart counter is at 1.

i have never changed something in the settings.js :frowning:

Then there is a good chance your SD card is failing

Thats a bad news. :frowning:
A few weeks ago i cloned thr card, but the new sd wont work too. With the new one the rasp dont boot :frowning:
Thats a bad situation niw i think

Should i try to remove the file and let them recreating by Node-red - but first i think i should try to clone the card...

I have set a up a new installation on a new card with my saved Nodered Config. Only Grafana and Influx isnt wokring a the moment. Hope i will get it running again too

An SD card is not the ideal storage for influxdb. Unless you have only a small amount of data I Recommend using a USB disc.

I use an SSD for the measurement data. The second SD card also appears to be broken. I set up a Node Red instance on a Windows Mini PC and it works, but without Grafana and Influx.
I gave the card to a colleague and he is trying to restore the original card - i hope he is successfull.
In any case, as a lesson for the future, I will only support the operating system on an SSD

After a few days on a windows machine i set up a new system on a ssd and got the most things working.
The last thing i have to do is to get change the influxdb config, that it will write the data on the 2nd ssd - where the old data are stored. The question is - do i have to just change the path or export the data from the old storge and import it on the new one. Thats the last part i have to figure out.

For all with the same problem:

I wasnt able to downgrade so i did this quickfix for me:

nano ./.node-red/node_modules/node-red-contrib-fronius-solar/fronius/fronius.js

change line 83:
fronius.GetPowerFlowRealtimeData(node.options).then(function(json) { // eslint-disable-line
fronius.GetPowerFlowRealtimeDataData(node.options).then(function(json) { // eslint-disable-line

save and restart node-red.

So i got the version 1.0.4 running.

A functionable SD Card oder SSD is recommended :smiley:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.