Function not configured correctly?


So, this a something that I noticed when I installed node-red on a windows server 2016.


the function node says it hasn't been configured correctly but, it seems to be working okay. Is there something I need to change?

Thanks in Advance.

Hi @KevinPamu - your flow export only includes the debug node, so we can't see what you have in your Function node.

Oops I didn't notice that,

[{"id":"b962629c.8f063","type":"function","z":"6d88a3be.4aed1","name":"","func":"var x = msg.payload;\nmsg.payload = x;\nreturn msg;","outputs":1,"noerr":2,"x":1622.8572463989257,"y":131.4285659790039,"wires":[["ebb238cf.5499d8"]]},{"id":"1ad6a14b.9d9cd3","type":"inject","z":"6d88a3be.4aed1","name":"","topic":"","payload":"","payloadType":"date","repeat":"","crontab":"","once":false,"onceDelay":0.1,"x":1405.7144077845982,"y":127.14284787859236,"wires":[["b962629c.8f063"]]},{"id":"ebb238cf.5499d8","type":"debug","z":"6d88a3be.4aed1","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"false","x":1840.00010572161,"y":134.28570543016707,"wires":[]}]

Here is the full flow.

If you open the node's edit dialog and close it again, it should clear the error.

I tried that, did not seem to help. This is happening with all my function nodes that I make changes to and deploy.

Can you stop node red and restart it from a terminal and post the log here please? That will show us what versions of everything you have and whether there are any obvious problems. I don't know about a Windows install but you may be able to do that using


@Colin , this is not on a Pi so those commands are meaningless.

@KevinPamu what version of Node-RED are you using?

@knolleary v0.20.5 is what I have installed on the Windows Server 2016 machine.

When you open it's edit dialog, does the text editor show any errors?

@knolleary No, it doesn't. I believe this occurs only when I run it on the windows server 2016. I have several other instances of the same flows on windows 10 that do not show the error message.

Hence why I phrased my point the way I did. It would still be worth seeing the startup log wouldn't it?


hey @Colin,

This is what I get when I start NR

Welcome to Node-RED

25 Apr 15:43:16 - [info] Node-RED version: v0.20.5
25 Apr 15:43:16 - [info] Node.js  version: v10.15.3
25 Apr 15:43:16 - [info] Windows_NT 10.0.14393 x64 LE
25 Apr 15:43:21 - [info] Loading palette nodes
25 Apr 15:43:28 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
25 Apr 15:43:30 - [info] Settings file  : ****
25 Apr 15:43:30 - [info] Context store  : 'default' [module=memory]
25 Apr 15:43:30 - [info] User directory : ****
25 Apr 15:43:30 - [warn] Projects disabled : editorTheme.projects.enabled=false
25 Apr 15:43:30 - [info] Flows file     : ****
25 Apr 15:43:30 - [info] Server now running at
25 Apr 15:43:30 - [warn]

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

OK, nothing obvious out or order there.

I was thinking the same. I am not sure if the windows version somehow affects the node?

The behaviour you are describing is entirely within the editor in the browser. The version of node.js is not very relevant.

What browser are you using to access the editor? Are you using different browsers when trying on the different machines?

Ah, That could be it. It was internet explorer.