How to inject a payload using a PLC


#21

Do you know why that did not work? If it should work but doesn't then I would first find out why it doesn't work. First I suggest trying it running node-red on a PC to communicate with the PLC. Then when you have got that going move it to the concentrator.


#22

I assume by that that you mean you connected them both to the router on our local network. Not that you connected an ethernet cable between them.


#23

Hi @Colin,

I've tried first running the NodeRed from the PC and triying to communicate with a TCP/IP emulator working as an slave. Since I have Nodered in the PC I can install more blocks and I tried with Modbusplc blocks. reading from the configuration of the plc emulator and is not working.

I've checked the ip's and all the configuration several times and it can't read anything.

I've tried also sending from nodered to the PLC.

I attach some pictures


#24

And here goes the configuration of the readings


#25

You should have the IP address of the PLC as the server.


#26

Yes, I am using the IP of the PLC I got in the emulator

PlcConfig


#27

I don't know why you are bothering with an emulator, why not just get it going in the PLC?

However, show us the config of the server in node red (click on the pen next to the server field).


#28

Captura


#29

Presumably your simulator has some sort of log that may show why it is not connecting. Also look in the node red log to see if there is anything there.

But as I said, personally I wouldn't worry about trying to debug the simulator.


#30

Hi everyone.

Thank you for your responses. I could make it work. I connect my Conduit via Ethernet and I made a bridge on it pointing to my LAN. My PLC and my Weintek are also connected to that LAN

In the NodeRed part I used the module TCP using the port 4000 (below 1000 didn't work)

Regards


#31

Port numbers below 1024 are usually reserved and unusable for us normal folk.