How to install a Amazon Dash Button node?

#1

hi,

the whole evening i tried to install one of the two dash-button nodes. The problem is that on both available nodes i need to install other things before which won´t work ...

first is:

npm -g install node-red-contrib-mydash

### requires tcpdump and expect to be installed on the system
apt-get install expect tcl8.6 tcpdump
pacman -S expect tcpdump

this installation ends with a message that the package can not be found

the other one is:

npm install node-red-contrib-amazondash

# dependancy on libpcap for reading packets
$ sudo apt-get install libpcap-dev
npm install node-red-contrib-amazondash

... the same like the first node

... i don´t know why but the installation won´t work.
do i need to do something special ? My nodered runs on a RPi Rasbian.

thanks in advance

0 Likes

#2

Did you try doing what it said to do and running those two commands?

0 Likes

#3

Yes of course. But both Shows me at the end that the package of those additional things cannot be found at E:/

0 Likes

#4

Where are you running the command ? E: sounds like a windows disk ? You should be running it on the pi. Just run the apt ones. Pacman is for a different version of Linux. You'll probably need sudo apt-get ...

0 Likes

#5

That´s the responce when i use sudo in front of ...

~ $ sudo apt-get install expect tcl8.6 tcpdump
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Paket tcl8.6 ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.
Doch die folgenden Pakete ersetzen es:
libtcl8.6

E: Paket expect kann nicht gefunden werden.
E: Für Paket »tcl8.6« existiert kein Installationskandidat.
E: Paket tcpdump kann nicht gefunden werden.

0 Likes

#6

Did you try that suggestion?

Colin

0 Likes

#7

i tried but ...

~ $ sudo apt-get install libtcl8.6
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
libtcl8.6 ist schon die neueste Version (8.6.6+dfsg-1).
libtcl8.6 wurde als manuell installiert festgelegt.
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
lxkeymap python-cairo python-gobject python-gobject-2 python-gtk2
python-xklavier
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 4 nicht aktualisiert.

then i want to install the node:

~ $ sudo npm install node-red-contrib-mydash
npm WARN saveError ENOENT: no such file or directory, open '/home/pi/package.json'
npm WARN enoent ENOENT: no such file or directory, open '/home/pi/package.json'
npm WARN pi No description
npm WARN pi No repository field.
npm WARN pi No README data
npm WARN pi No license field.

  • node-red-contrib-mydash@1.0.0
    added 1 package in 3.063s

after that i checked if there´s a node red update and start that ...

now it´s strange the "manage pallet" shows me that the mydash-node is installed but it is not in the list.

0 Likes

#8

so ... after update npm i -g npm i cannot reach node red at the local ip :confused:

i think i need to rebuild the installation. what is the easiest way to uninstall an install node-red on a raspian ?

0 Likes

#9

Rename your .node-red folder and run the bash <(curl script again. That will reset most stuff. If you have installed any additional nodes globally (which is not normal) then uninstall them.

0 Likes

#10

I would be a bit concerned about node-red-contrib-mydash. It hasn't had an update in two years and there isn't a link to the source on npmjs.

0 Likes

#11

Hi, rename the folder and run the bash script works ... So now I need to search for another solution to use the Amazon dash button.
I saw that there's another way. This uses the UDP node to listen on Port 67 ... But there it shows me that I need root. How can I use/solve that?

0 Likes

#12

ahhh ... i found the problem ! after i do a sudo update it´s possible to install everything recomended for the amazon dash node.
It works !!!! thanks a lot to

0 Likes