I am having trouble opening excel files when using the Excel Sheets node

I tried to use The Excel Sheets node to write data, but it couldn't be opened after writing. I don't know what the problem is, please help me solve it or give me an example, thank you

Welcome to the forum. Can you explain what you mean by couldn't be opened?

Also exactly which node are you using to write? node-red-contrib-something probably.

Hello, I use a node - red - contrib - excelsheets node, I used the making the example above, but after the completion of the operation, did not write data in excel spreadsheet, or display file is damaged, I want to seek an instance about the specific use of the node, thank you

I haven't used that node. Does it work if you try it with the example provided?

Hello, you can find that in this instance, it is making links: GitHub - mdkrieg/node-red-contrib-excelsheets, if you are successful, please tell me, thank you

I am sorry, I don't understand what you mean.

I tried the example in GitHub page ( node-red-contrib-excelsheets/basic.json at main · mdkrieg/node-red-contrib-excelsheets (github.com) ), but it's not working, the sheet been produced is damaged and can't been open, could you check is that example working on your computer please? Thank you very much!

No, you are right, it does not work. I suggest adding an issue on the node's github page, or is the issue that was added a few hours ago from you? If it is from you then I suggest adding details about the OS you are running on, node-red and nodejs versions and any other details you can think of. If it isn't from you then I suggest that you add a comment saying that you have the problem too and giving those details.

Should be all fixed now. It was an issue with detecting between the two input formats, noob mistake on my end (Arrays are objects too duh!)

If you update to v1.1.1 it should be good to go.

1 Like

Yes, I raised that question, and now it has been solved, thank you