Installation error node-red-node-arduino

Greetings, folks.

I am facing a problem when installing the "node-red-node-arduino" in the "manege palette" of Node-Red. Whenever I try to install through the graphical interface it throws the following error:

"Failed to install: node-red-node-arduino

Error: Install failed

Check the log for more information "

If anyone can help me, thank you very much.

Have you checked the log for more information?

Was in process of updating that very node this evening - version 0.1.0 will be on npm shortly with latest serialport and firmata handler so hopefully will play nicer with node 10 etc.

I run in the same error today. Installing no-red-node-arduino Fails - also after update/upgrade Raspberry pi. Some Information from the log file:

510 verbose about to build /home/pi/.node-red/node_modules/node-red-node-arduino
511 verbose node_modules/node-red-node-arduino unbuild
512 info preuninstall node-red-node-arduino@0.2.2
513 info uninstall node-red-node-arduino@0.2.2
514 verbose true,/home/pi/.node-red/node_modules,/home/pi/.node-red/node_modules unbuild node-red-node-arduino@0.2.2
515 info postuninstall node-red-node-arduino@0.2.2
516 error Error: Method Not Allowed
516 error at errorResponse (/usr/share/npm/lib/cache/add-named.js:260:10)
516 error at /usr/share/npm/lib/cache/add-named.js:203:12
516 error at saved (/usr/share/npm/node_modules/npm-registry-client/lib/get.js:167:7)
516 error at FSReqWrap.oncomplete (fs.js:135:15)
517 error If you need help, you may report this entire log,
517 error including the npm and node versions, at:
517 error http://github.com/npm/npm/issues
518 error System Linux 4.14.98-v7+
519 error command "/usr/bin/node" "/usr/bin/npm" "i" "--unsafe-perm" "node-red-node-arduino"
520 error cwd /home/pi/.node-red
521 error node -v v8.11.1
522 error npm -v 1.4.21
523 error code E405
524 verbose exit [ 1, true ]

you need to upgrade node.js and npm in particular. npm 1.4.2 is somewhat broken.
If this is a Pi then use the upgrade script we provide.

Thank you very much, that gives hope for me! But where is the offered upgrade switch - I have no idea?

in the documentation > getting started > raspberry pi

Ok - I followed the given way....
The horrible lengthly command "bash <(curl...) will do Nothing. So I'm at the same point as before.

when you say the bash command (which you can copy and paste) does nothing, what do you mean?

It’s a lot easier to suggest what you could do if you describe what actually happens

sorry - "does nothing" means: after the Enter-key the Raspberry pi goes immediately back to prompt - without a visible action. What should be the result of this command?

pi@RaspKlar:~ $ bash <(curl -sL https://raw.githubusercontent.com/node-red/raspbian-deb-package/master/resources/update-nodejs-and-nodered)

pi@RaspKlar:~ $

It should take quite a long time (quite a few minutes) and produce output showing progress along the way. Has the Pi got internet access? If not then it won't work. If it has then what happens if you just run the curl command
curl -sL https://raw.githubusercontent.com/node-red/raspbian-deb-package/master/resources/update-nodejs-and-nodered

That should echo a whole load of stuff to the ternimal, ending with something like
if [ -e /tmp/update-nodejs-and-nodered ] && [ -s /tmp/update-nodejs-and-nodered ]; then sudo mv /tmp/update-nodejs-and-nodered /usr/bin/update-nodejs-and-nodered; fi