Lost connection to server, reconnecting... (DietPi)


today I tried to install a fresh Node-RED on DietPi Bookworm, but immediately get the error message "Lost connection to server, reconnecting".
There is no Firewall active and everything else should be like "out-of-the-box".

System is
Node-Red v3.1.3
Node v21.6.1 (that's DietPi...)

and only mosquitto, ufw (disabled) and RPi.GPIO installed...

Any ideas, where I have to search for this problem?

Thanks in advance!

I would start by going back to supported version of nodejs, 18 or 20.

Seems - for me - not to be possible.
If I use the dietpi-software command I only get this versions...

Alright, I got it:

  1. uninstall node-red again

dietpi-software uninstall 122

  1. install Node.js (LTS should be best, right?)

curl -fsSL https://deb.nodesource.com/setup_lts.x | bash - &&
apt-get install -y nodejs

  1. install node-red via dietpi-software

dietpi-software install 122

Seems to work now, but I will go back 2 steps and try again, just to make sure, that this is the right way!

Thank you so far!


Didn't work. After a reboot Version 21.6.1 was the version, that node -v showed up...

1 Like

I was wrong...

The httpAdminRoot was at "/Admin" - and opening "/admin" worked so far - except the websocket connection... How bad... :thinking:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.