Missing Node after Installation


I tried to install the @mindconnect lib in my node-red on VM and I got positive feedback - but the node does not appear in the nodes list in the browser framework. I tried it with palette installation and with npm, both the same. On my local computer it works like it should. When I copie a flow from this computer the node is marked as unknown node - but it is used in the flow in background.

Is there any idea why this node is not implemented in the browser framework in this case?

Thanks in advance and kind regards

it would help if you specified

  1. the exact name of the node (node-red-contrib-????) that you are trying to use
  2. what type of VM
  3. what version of Node-red, and node.js (you can get these from the node_red startup log) in the VM and on the Pi
  4. what does the startup log show on the VM? Any error/warning messages?

If you import a flow into another occurance of node-red and a node shows up outlined then it is not installed there.

Thank you for quick reply.

  1. It is the node @mindconnect/node-red-contrib-mindconnect.
  2. It is a Windows VM on Remote Server (Windows Server 2019 Datacenter).

That are the informations I believe you asked for, correct?

What do you see if you click on the > 1 Node button? Also what does the other button translate as please? I can't read it on the screenshot.

It looks like you already have node red running or a conflict with the address. Note in the log the EADDRINUSE message

The >1 Node button has only the node "Mindconnect" in.

This node is my problem. It is mentioned in the palette as installed - but in the browser flow it is unknown and I cannot edit it. In the flow information of the npm console it is mentioned with an error - this is because of wrong data that I cannot edit.

I see the node in the palette, it is used in the flow (because I get error-messages in th console) but I cannot edit in the browser.

@zenofmud - you are right in my first screenshot the node-red was allready running. I forgot to stop it before starting p again. This is the normal start-up:

and if you refresh the browser now you have restarted node-red, is the mindconnect node present and correct?

I started several times and I already renewed the whole installation of node.js and node-red - with the same results.

Perhaps this issue is related?

are you getting errors in debug console of the browser?

WAIT :eyes: ...
is that ... is it ... is that internet explorer you are using? (YUK)

Try something better like Chrome :wink: (or at least edge)

1 Like

@Steve-Mcl - you are right! It is a problem of iexplorer - in chrome it works like I expected.

Thanks a lot friends ...

Lesson learned - NEVER use internet explorer - it is the absolute bane of developers

PS, it would be worth posting an issue on the repo for the developers to know (they ultimately might not care - but it would be good to let them know what issues you had)

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.