MOXA Serial Convertor: "node-red-node-serialport" node - Resolved

I want to use a MOXA N5100A serial convertor to input an RS232 stream to Node-Red.

Node-Red is running on a Raspberry Pi 4, Raspian OS.

In Node-Red, I am using the "node-red-node-serialport" node.

I have successfully loaded the TTY drivers for the MOXA N5100 and mapped TTY ports to the IP address of the N5100. Here is a screenshot of the RPI console showing the TTY port mapping:

MOXA Tech Support says I need to look for the "ttyr00" TTY port in Node-Red. However, I do not see that port format. Here is a screenshot of the port selection provided by the "node-red-node-serialport" node:

After selecting the "/dev/tty/SO" port, I received the error message shown. I am not sure if this is the same as the "ttyrOO" port that the MOXA driver mapped??

I need help to configure the "node-red-node-serialport" node to the MOXA "ttyrOO" port?



Wanted to provide an update, but still need help.

I found I could type in the tty port into the "node-red-node-serialport" node.

So, I typed in "ttyr00" into the port box. Here is a screenshot. "node-red-node-serialport" gives the message, ""serial port /dev/ttyr00 error: Error: Error: No such file or directory, cannot open /dev/ttyr00"?


You need to start by doing a listing of your serial devices:

ls -la /dev/tty*

To find out their ownership.

Then you need to make sure that the user id running Node-RED belongs to the appropriate group. Probably dialout or tty. That should deal with the permission error.

Thanks TotallyInformation.

With your help and other ideas, I was able to re-install the MOXA TTY drivers and get a successful Node-Red connection.


Hello. it seems i have the same problem. Could u tell me how u fixed it?


Its been a while and I do not recall the details.

I found the "read me" which is included with the MOXA "real com" driver download worked for me after I got past the "extraction" steps.

Then I had to change permissions to the "dev" files to allow Node-Red to access them.

In the end, I changed to using an IP address, instead of a COM port, from the MOXA serial converter. The Node-Red TCP node was much easier, for me, to set up.


1 Like